Opened 10 years ago

Closed 10 years ago

#26968 closed defect (fixed)

Status 1 encountered when building db46

Reported by: acampbell3000@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: christopherson.scott@…
Port: db46

Description

Hello,

I've just tried to install ffmpeg. I encountered status 1 when building the db46 dependency.

New to the project so don't know you expect me to raise dependency issues. However, I think it's better to try and get feedback and follow the process prompted in the console output.

Attachments (1)

db46.log (483.6 KB) - added by acampbell3000@… 10 years ago.
Log output

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by acampbell3000@…

Attachment: db46.log added

Log output

comment:1 Changed 10 years ago by christopherson.scott@…

Cc: christopherson.scott@… added

Cc Me!

comment:2 Changed 10 years ago by christopherson.scott@…

I have the exact same issue when trying to install apache2.

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Keywords: ffmpeg db46 removed
Owner: changed from macports-tickets@… to blair@…

comment:4 Changed 10 years ago by worldleather

ffmpeg-devel failed to install. log shows db46 failed to build. java related. I was told this can be fixed by installing the Java for Mac OS X 10.6 Update 3 Developer Package. I installed this package and now it works.

comment:5 in reply to:  4 Changed 10 years ago by acampbell3000@…

Replying to a00ps@…:

ffmpeg-devel failed to install. log shows db46 failed to build. java related. I was told this can be fixed by installing the Java for Mac OS X 10.6 Update 3 Developer Package. I installed this package and now it works.

I'm still having problems. Yes, the log I uploaded shows unable to build db46 with Java errors. However, update 3 developer package did not make a difference to me.

comment:6 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #26939; please search before filing new tickets.

comment:7 Changed 10 years ago by christopherson.scott@…

ffmpeg-devel failed to install. log shows db46 failed to build. java related. I was told this can be fixed by installing the Java for Mac OS X 10.6 Update 3 Developer Package. I installed this package and now it works.

The developer package update did nothing for me either.

comment:8 Changed 10 years ago by acampbell3000@…

Resolution: duplicate
Status: closedreopened

Reading the trac listing, a lot of people have had success. How can we ensure that port is using the JDK developer package version of Java?

comment:9 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

This is a duplicate of #26939; please do not re-open. If you still experience issues after installing the appropriate developer package, please ensure you have cleaned the port ("sudo port clean db46") and if that still doesn't help, attach the new main.log to #26939.

Note: See TracTickets for help on using tickets.