Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26978 closed defect (fixed)

libgtkhtml3 @3.30.3 - build failure

Reported by: bugs1309@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: libgtkhtml3

Description

I wanted to upgrade my ports installation with the following command: {{sudo port -n upgrade --enforce-variants outdated}}.

It fails during the build of libgtkhtml3 with the following output:

--->  Building libgtkhtml3
Error: Target org.macports.build returned: shell command failed
Log for libgtkhtml3 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgtkhtml3/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

The logfile of the build step is attached.

Attachments (1)

main.log (18.2 KB) - added by bugs1309@… 10 years ago.
Build log file

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by bugs1309@…

Attachment: main.log added

Build log file

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Why are you using -n and --enforce-variants? The former prevents dependencies from being upgraded before their dependents, which can definitely cause problems. The latter isn't useful unless you specify at least one variant that you want to add or remove.

comment:2 Changed 10 years ago by dbevans (David B. Evans)

Resolution: fixed
Status: newclosed

Fix committed in r72696.

comment:3 in reply to:  1 Changed 10 years ago by bugs1309@…

Replying to jmr@…:

Why are you using -n and --enforce-variants? The former prevents dependencies from being upgraded before their dependents, which can definitely cause problems. The latter isn't useful unless you specify at least one variant that you want to add or remove.

I assumed that port upgrade -n outdated will upgrade all packages that are changed, so I should have no problems with outdated dependencies. Are you suggesting that -n screws up the order of the build process? Anyway, this was not the cause of the problem.

Note: See TracTickets for help on using tickets.