Opened 10 years ago

Closed 10 years ago

#26980 closed defect (fixed)

step by step port install causes error was "kdepimlibs4 fails to install"

Reported by: mkae (Marko Käning) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: nerdling (Jeremy Lavergne), sharky@…, ygramul.el.multiple@…
Port: kdepimlibs4

Description

I tried to install kdepimlibs4, using the attached patch to use KDE4 port group 1.1 but it actually complains about "no rule to make target 'install'".

DEBUG: Skipping completed org.macports.build (kdepimlibs4)
--->  Staging kdepimlibs4 into destroot
. missing (directory not created: File exists)
./Applications missing (directory not created: File exists)
./Developer missing (directory not created: File exists)
./Library missing (directory not created: File exists)
DEBUG: destroot phase started at Sun Oct 24 15:42:26 CEST 2010
DEBUG: Executing org.macports.destroot (kdepimlibs4)
DEBUG: Environment: CPATH='/opt/macports-test/include' CC_PRINT_OPTIONS_FILE='/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/.CC_PRINT_OPTIONS' QTDIR='/opt/macports-test' LIBRARY_PATH='/opt/macports-test/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6' INSTALL_ROOT='/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/destroot' DESTDIR='/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/destroot' MOC='/opt/macports-test/bin/moc' QMAKE='/opt/macports-test/bin/qmake'
DEBUG: Assembled command: 'cd "/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/kdepimlibs-4.4.5" && /usr/bin/make install DESTDIR=/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/destroot'
make: *** No rule to make target `install'.  Stop.
shell command " cd "/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/kdepimlibs-4.4.5" && /usr/bin/make install DESTDIR=/opt/macports-test/var/macports/build/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/work/destroot " returned error 2
Error: Target org.macports.destroot returned: shell command failed
DEBUG: Backtrace: shell command failed
    while executing
"command_exec destroot"
    (procedure "portdestroot::destroot_main" line 2)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for kdepimlibs4): org.macports.activate org.macports.destroot org.macports.install
Log for kdepimlibs4 is at: /opt/macports-test/var/macports/logs/_Users_marko_WC_MacPorts_ports_kde_kdepimlibs4/main.log
Error: Status 1 encountered during processing.

Attachments (1)

kdepimlibs4.diff (102 bytes) - added by mkae (Marko Käning) 10 years ago.
KDE4 port group 1.1

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by mkae (Marko Käning)

Attachment: kdepimlibs4.diff added

KDE4 port group 1.1

comment:1 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: invalid
Status: newclosed

I appreciate the help, but getting tickets from people applying patches that haven't been released into MacPorts won't help. How you built kdelibs will impact all the other dependencies, and applying the patches incorrectly will lead to issues as well. Please wait for the release.

comment:2 Changed 10 years ago by mkae (Marko Käning)

OK, snc, you are certainly right, I'll wait for the release then.

comment:3 Changed 10 years ago by mkae (Marko Käning)

Resolution: invalid
Status: closedreopened

The error above mentioned is the same like the one described for kdelibs4 here

And the solution is the same: sudo port clean; sudo port install

Don't know why it wasn't possible to do the usual step by step procedure of configure, build, destroot and install! That's the bug here!!!

The suggested patch above actually worked fine with the current version of kdepimlibs4.

comment:4 Changed 10 years ago by mkae (Marko Käning)

Summary: kdepimlibs4 fails to installstep by step port install causes error was "kdepimlibs4 fails to install"

comment:5 Changed 10 years ago by ygramul.el.multiple@…

Cc: ygramul.el.multiple@… added

Cc Me!

comment:6 Changed 10 years ago by michaelld (Michael Dickens)

Cc: michaelld@… removed

Cc Me!

comment:7 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: reopenedclosed

This issue should have been fixed with r74206, so I'm closing this ticket since step-by-step building of KDE ports work for me as of that revision.

Note: See TracTickets for help on using tickets.