Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#26986 closed defect (duplicate)

libgtkhtml3 @3.30.3 build failure

Reported by: theckman@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: libgtkhtml3

Description

While trying to upgrade gnucash, I ran into the following. Uninstall / reinstall gives the same result.

:msg:main --->  Building libgtkhtml3
:debug:build build phase started at Sun Oct 24 19:41:08 EDT 2010
:debug:build Executing org.macports.build (libgtkhtml3)
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgtkhtml3/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgtkhtml3/work/gtkhtml-3.30.3" && /usr/bin/make -j2 all'
:info:build /usr/bin/make  all-recursive
:info:build Making all in a11y
:info:build make[2]: Nothing to be done for `all'.
:info:build Making all in gtkhtml
:info:build   CC     htmlcluealigned.lo
:info:build   CC     gtkhtml.lo
:info:build   CC     htmlclueflow.lo
:info:build gtkhtml.c: In function 'focus_in_event':
:info:build gtkhtml.c:2157: error: implicit declaration of function 'GTK_OBJECT_FLAGS'
:info:build gtkhtml.c:2157: warning: nested extern declaration of 'GTK_OBJECT_FLAGS'
:info:build gtkhtml.c:2157: error: lvalue required as left operand of assignment
:info:build gtkhtml.c: In function 'focus_out_event':
:info:build gtkhtml.c:2188: error: lvalue required as left operand of assignment
:info:build gtkhtml.c: In function 'gtk_html_init':
:info:build gtkhtml.c:3417: error: lvalue required as left operand of assignment
:info:build gtkhtml.c:3418: error: lvalue required as left operand of assignment
:info:build make[2]: *** [gtkhtml.lo] Error 1
:info:build make[2]: *** Waiting for unfinished jobs....
:info:build make[1]: *** [all-recursive] Error 1
:info:build make: *** [all] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_libgtkhtml3/work/gtkhtml-3.30.3" && /usr/bin/make -j2 all " returned error 2
:error:build Target org.macports.build returned: shell command failed
:debug:build Backtrace: shell command failed
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"

Change History (2)

comment:1 Changed 10 years ago by dbevans (David B. Evans)

Port: libgtkhtml3 added
Resolution: duplicate
Status: newclosed

Duplicate of #26978 which is now fixed.

Please run

sudo port selfupdate
sudo port clean libgtkhtml3

and try again.

comment:2 Changed 10 years ago by theckman@…

Fixed. Thank you.

Note: See TracTickets for help on using tickets.