Opened 10 years ago

Closed 10 years ago

#27007 closed defect (fixed)

kdenlive fails to build because of dependency failure

Reported by: mark6691@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: nerdling (Jeremy Lavergne), sharky@…
Port: kdenlive qimageblitz

Description

This is actually related to Ticket #26988. I apologize if I was unclear in the description. The failure is because kdebase4-runtime fails due to kdelibs4. In addition, qimageblitz fails. Both failures report shell command failed. Log files are attached.

BTW, attica worked after the fix. If kdebase4-runtime, kdelibs4, and qimageblitz can be fixed, I just may finally get a fully working install of kdenlive on my Mac OS X 10.5.8, which (as mentioned in Ticket # 26988) is a completely fresh install.

Attachments (4)

main.log (31.7 KB) - added by mark6691@… 10 years ago.
main.2.log (5.4 KB) - added by mark6691@… 10 years ago.
main.3.log (32.7 KB) - added by mark6691@… 10 years ago.
main.4.log (4.2 KB) - added by mark6691@… 10 years ago.

Download all attachments as: .zip

Change History (25)

Changed 10 years ago by mark6691@…

Attachment: main.log added

Changed 10 years ago by mark6691@…

Attachment: main.2.log added

Changed 10 years ago by mark6691@…

Attachment: main.3.log added

comment:1 Changed 10 years ago by mark6691@…

This time I hope I've provided all the necessary information. I might mention that there were a host of other dependencies that did not get installed because of the failure of kdebase4-runtime, but I got them one by one until I hit this final stopping point which I feel is because of kdelibs4 and qimageblitz.

comment:2 Changed 10 years ago by mark6691@…

Oh, and I've taken care of the firewall issues at work, so I'll be monitoring all day to check for ticket updates, or any questions. Thank you for all you do; I am really looking forward to finally getting this to work. When the new version of kdenlive is released, please mention any caveats that I'll need to observe. Thanks, again.

comment:3 Changed 10 years ago by nerdling (Jeremy Lavergne)

Keywords: Status 1 encountered during processing. removed
Resolution: worksforme
Status: newclosed

Please do selfupdate and try again: your builds are for outdated versions.

Changed 10 years ago by mark6691@…

Attachment: main.4.log added

comment:4 in reply to:  3 Changed 10 years ago by mark6691@…

Resolution: worksforme
Status: closedreopened

Replying to snc@…:

Please do selfupdate and try again: your builds are for outdated versions.

Done, fails again adding more dependencies. In addition to kdebase4-runtime, kdelibs4, qimageblitz, there is now dbusmenu-qt, qjson, and openslp. Do I need to quit trying to use subversion, blow it all away and use the Mac package? Or use the source install? There has to be a way to make this thing work.

comment:5 Changed 10 years ago by mark6691@…

Just got the last 3: dbusmenu-qt, qjoson, and openslp. Remaining are kdebase4-runtime, kdelibs4, and qimageblitz. The problem is kdelibs4 attempting to fetch add-bundles-to-patch.patch, assuming that is still a work in progress. Will keep trying to "clean" and "selfupdate" and "install" kdelibs4. Still getting "shell command failed" with qimageblitz.

comment:6 Changed 10 years ago by nerdling (Jeremy Lavergne)

Sigh. I clobbered my diffs. Now to figure out if the patches were needed or not.

comment:7 in reply to:  6 Changed 10 years ago by mark6691@…

Replying to snc@…:

Sigh. I clobbered my diffs. Now to figure out if the patches were needed or not.

Boy, I wish I knew how to do what you guys do. I'd love to be able to contribute in some way.

comment:8 Changed 10 years ago by nerdling (Jeremy Lavergne)

The patch files do indeed work, so they need checked in again (can we do a merge revert?). Checking... in the mean time follow #27017 for the patchfile issue.

comment:9 in reply to:  8 ; Changed 10 years ago by mark6691@…

Replying to snc@…:

The patch files do indeed work, so they need checked in again (can we do a merge revert?). Checking... in the mean time follow #27017 for the patchfile issue.

Getting there, one step at a time. Kdelibs4 worked, now installed. Now if qimageblitz will pass the "shell command failed" error, kdebase4-runtime will likely install which should allow kdenlive to complete installation.

comment:10 in reply to:  9 Changed 10 years ago by mark6691@…

Replying to mark6691@…:

Replying to snc@…:

The patch files do indeed work, so they need checked in again (can we do a merge revert?). Checking... in the mean time follow #27017 for the patchfile issue.

Getting there, one step at a time. Kdelibs4 worked, now installed. Now if qimageblitz will pass the "shell command failed" error, kdebase4-runtime will likely install which should allow kdenlive to complete installation.

How does one do a merge revert? Tried to Google it, but it wasn't making a whole lot of sense.

comment:11 Changed 10 years ago by nerdling (Jeremy Lavergne)

I mean "revert changes by merging"

svn merge -r head:### 

I basically "undo" from now back to a good point, and then check that in. It preserves the history then rather than wiping it out if I added the files again.

comment:12 in reply to:  11 ; Changed 10 years ago by mark6691@…

Replying to snc@…:

I mean "revert changes by merging"

svn merge -r head:###

I basically "undo" from now back to a good point, and then check that in. It preserves the history then rather than wiping it out if I added the files again.

I think my problem would be that I don't have a prior known good point, since this is being done on a completely new installation of Mac OS X. Also, I'm unfamiliar with the term "head" and how to determine the number. Biggest problem is not knowing the language, I guess.

comment:13 in reply to:  12 ; Changed 10 years ago by nerdling (Jeremy Lavergne)

Replying to mark6691@…:

It's quite alright. HEAD and PREV are defined, as the current and previous revisions. I took care of reverting it, and thus the ticket for it was closed (trac puts a strikethrough on the ticket reference).

comment:14 in reply to:  13 ; Changed 10 years ago by mark6691@…

I've tried again with cleaning ports from kdenlive on down to qimageblitz, doing the selfupdate, etc... with the same results. Then I decided to clean all installed ports, etc... and still the same end result. Qimageblitz is killing everything. I don't know what else to do.

comment:15 in reply to:  14 Changed 10 years ago by mark6691@…

Replying to mark6691@…:

I've tried again with cleaning ports from kdenlive on down to qimageblitz, doing the selfupdate, etc... with the same results. Then I decided to clean all installed ports, etc... and still the same end result. Qimageblitz is killing everything. I don't know what else to do.

One last question: Shall I completely uninstall MacPorts subversion and everything with it, and use the .dmg package? Going to lunch briefly, will check back upon return. Thanks.

comment:16 Changed 10 years ago by mark6691@…

It may not be so good to be on "the bleeding edge".

comment:17 in reply to:  16 Changed 10 years ago by mark6691@…

Replying to mark6691@…:

It may not be so good to be on "the bleeding edge".

After a lot of reading (other related tickets), the problem is most definitely with qimageblitz and its inability to recognize that phonon is in fact installed. I hope someone finds a solution.

comment:18 Changed 10 years ago by nerdling (Jeremy Lavergne)

Port: qimageblitz added

comment:19 Changed 10 years ago by nerdling (Jeremy Lavergne)

I took over and updated qimageblitz: r72871.

comment:20 Changed 10 years ago by jmroot (Joshua Root)

So did the update fix this?

comment:21 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: reopenedclosed

Latest kdenlive installs fine for me so I assume this got fixed somewhere along the way.

Note: See TracTickets for help on using tickets.