Opened 10 years ago

Closed 10 years ago

#27024 closed defect (fixed)

qtscriptgenerator fails to build : phonon?

Reported by: develop@… Owned by: michaelld (Michael Dickens)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: drw392772@…, erikfrerejean@…
Port: qtscriptgenerator

Description

Hello, another qt related problem I suppose.

When building qtscriptgnerator I can see 2 different problems : 1st :

:info:build cd qtscript_phonon/ && make -f Makefile
:info:build make -f Makefile.Release
:info:build make[2]: *** No rule to make target `../../generated_cpp/com_trolltech_qt_phonon/main.cpp', needed by `release/main.o'.  Stop.
:info:build make[1]: *** [release] Error 2
:info:build make: *** [sub-qtscript_phonon-make_default] Error 2

Maybe related to the fact that phonon is not from qt4 anymore but a library autonomous?

And 2nd:

:info:build /opt/local/include/QtOpenGL/QtGui.framework/Headers/qmatrix4x4.h
:info:build WARNING(MetaJavaBuilder) :: enum 'QGraphicsItem::PanelModality' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QWebFrame::RenderLayer' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QTextDocument::Stacks' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QAbstractSocket::SocketOption' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QStyle::RequestSoftwareInputPanel' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QWebPage::ErrorDomain' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QGLContext::BindOption' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: Unable to decide type of property: 'NetworkAccessibility' in class 'QNetworkAccessManager'
:info:build WARNING(MetaJavaBuilder) :: enum 'QNetworkAccessManager::NetworkAccessibility' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: Unable to decide type of property: 'Qt::InputMethodHints' in class 'QWidget'
:info:build WARNING(MetaJavaBuilder) :: Unable to decide type of property: 'SoftKeyRole' in class 'QAction'
:info:build WARNING(MetaJavaBuilder) :: Unable to decide type of property: 'Priority' in class 'QAction'
:info:build WARNING(MetaJavaBuilder) :: enum 'QAction::Priority' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QAction::SoftKeyRole' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QXmlStreamReader::ReadElementTextBehaviour' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QDataStream::FloatingPointPrecision' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QPainter::PixmapFragmentHint' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QGradient::InterpolationMode' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: Unable to decide type of property: 'QEasingCurve' in class 'QTimeLine'
:info:build WARNING(MetaJavaBuilder) :: enum 'QNetworkRequest::Priority' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QNetworkRequest::LoadControl' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::GestureType' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::GestureFlag' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::GestureState' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::CoordinateSystem' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::TileRule' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::Initialization' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::AnchorPoint' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::NavigationMode' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::InputMethodHint' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'Qt::TouchPointState' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QtValidLicenseForOpenVGModule' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QtValidLicenseForDeclarativeModule' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'enum_2' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: enum 'QtValidLicenseForMultimediaModule' does not have a type entry or is not an enum
:info:build WARNING(MetaJavaBuilder) :: class 'QGraphicsWidget' inherits from unknown base class 'QGraphicsObject'
:info:build WARNING(MetaJavaBuilder) :: class not found for setup inheritance 'QGraphicsObject'
:info:build WARNING(MetaJavaBuilder) :: class 'QGraphicsTextItem' inherits from unknown base class 'QGraphicsObject'
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: QWebSettings::WebAttribute, LocalStorageDatabaseEnabled and LocalStorageEnabled$
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: QDataStream::Version, Qt_4_7 and Qt_4_6 are 12, already rejected: (Qt_4_1, Qt_4$
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::Modifier, SHIFT and META are 0, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::Modifier, CTRL and META are 0, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::Modifier, ALT and META are 0, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::Modifier, MODIFIER_MASK and META are 0, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::Modifier, UNICODE_ACCEL and META are 0, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: duplicate enum values: Qt::MouseButton, MiddleButton and MidButton are 4, already rejected: ()
:info:build WARNING(MetaJavaBuilder) :: unhandled enum value: static_cast<Qt::MatchFlags>(Qt::MatchExactly in Qt::MatchFlag
:info:build WARNING(MetaJavaBuilder) :: unhandled enum value: Qt::MatchCaseSensitive) in Qt::MatchFlag
:info:build WARNING(MetaJavaBuilder) :: unmatched enum static_cast<Qt::MatchFlags>(Qt::MatchExactly|Qt::MatchCaseSensitive) when parsing defau$
:info:build WARNING(MetaJavaBuilder) :: unmatched enum static_cast<Qt::MatchFlags>(Qt::MatchExactly|Qt::MatchCaseSensitive) when parsing defau$
:info:build Classes in typesystem: 522
:info:build Generated:
:info:build   - classes...: 503 (0)
:info:build   - header....: 339 (0)
:info:build   - impl......: 339 (0)
:info:build   - modules...: 10 (7)
:info:build   - pri.......: 10 (0)
:info:build
:info:build Done, 50 warnings (918 known issues)
:info:build cd qtscript_core/ && make -f Makefile

Maybe just warnings, not important?

If you need a debug log I can provide you, just tell me how. Thanks.

Attachments (1)

main.log (542.9 KB) - added by develop@… 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by develop@…

Attachment: main.log added

comment:1 Changed 10 years ago by develop@…

I forgot to Cc the maintainer (even if it is nomaintainer;-) I create the ticket but cannot modify the header, who stealed my ownership! :)))

comment:2 Changed 10 years ago by michaelld (Michael Dickens)

Owner: changed from macports-tickets@… to michaelld@…
Status: newassigned

This is probably related to removing phonon from qt4 and making it a separate install. Let me get phonon upgraded to using QMake instead of CMake, and then I'll revisit this ticket to see if its still valid. My hope is that by using QMake to compile phonon (and it's qt7 backend, which doesn't work with CMake / automoc4 yet), whatever the issue is with qtscriptgnerator will resolve itself. We'll see; first things first.

comment:3 Changed 10 years ago by drw392772@…

Cc: drw392772@… added

Cc Me!

comment:4 Changed 10 years ago by ak.ml@…

I had the same issue. Applying include_everything.patch as described in Ticket: #22158 worked for me.
I have a MacIntel with Leopard 10.5.8

comment:5 Changed 10 years ago by michaelld (Michael Dickens)

@ak.ml: Thanks for pointing out that fix; it looks promising! I'll get working on incorporating it & fixing the destroot issue I introduced (as you note in the posting to the dev list).

comment:6 Changed 10 years ago by erikfrerejean@…

Cc: erikfrerejean@… added

Cc Me!

comment:7 Changed 10 years ago by michaelld (Michael Dickens)

This is a complicated issue, but I think I've found a work-around (testing right now) using a variant of the fix from ticket #22158.

comment:8 Changed 10 years ago by michaelld (Michael Dickens)

Resolution: fixed
Status: assignedclosed

Should be fixed in r73106. I'm closing this ticket as fixed, but please do reopen if it doesn't work for you.

Note: See TracTickets for help on using tickets.