Opened 10 years ago

Closed 10 years ago

#27089 closed defect (invalid)

ghostscript fails to build

Reported by: awaterland@… Owned by: takanori@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: ghostscript

Description (last modified by mf2k (Frank Schima))

I've tried uninstalling and reinstalling xcode, as well as uninstalling and reinstalling macports itself.

--->  Building ghostscript
Error: Target org.macports.build returned: shell command failed
Log for ghostscript is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/main.log
Error: Status 1 encountered during processing.

:info:build /usr/bin/gcc-4.2  -DHAVE_MKSTEMP -DHAVE_HYPOT   -DHAVE_FONTCONFIG -DHAVE_LIBIDN -DHAVE_SETLOCALE -O2 -isystem/opt/local/include  -Wall -Wstrict-prot
otypes -Wundef -Wmissing-declarations -Wmissing-prototypes -Wwrite-strings -Wno-strict-aliasing -Wdeclaration-after-statement -fno-builtin -fno-common -DHAVE_STDINT_H -DGX_COLOR_INDEX_TYPE="unsigned long int" -pipe -O2 -arch x86_64 -DUSE_LI
BICONV_GNU -DUSE_LIBPAPER  -I./obj/../soobj -I./base  -g -o ./bin/../sobin/gsc .
/psi/dxmainc.c \
:info:build     -L./bin/../sobin -lgs
:info:build ld: in ./bin/../sobin/libgs.dylib, can't link with a main executable
:info:build collect2: ld returned 1 exit status
:info:build make[1]: *** [bin/../sobin/gsc] Error 1
:info:build make: *** [so] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/ghostscript-9.00" && /usr/bin/make so " returned error 2

Attachments (1)

main.log (85.3 KB) - added by awaterland@… 10 years ago.
Build log

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by awaterland@…

Attachment: main.log added

Build log

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to takanori@…
Port: ghostscript added

comment:2 Changed 10 years ago by takanori@…

I tried to re-install ghostscript from scratch but I couldn't reproduce your problem.

Anyway, could you show me a whole buildlog? You can obtain it like the following. Thanks.

    $ sudo port clean ghostscript
    $ sudo port install ghostscript
    (fail to build)
    $ port log ghostscript > ~/Desktop/buildlog_ghostscript.txt

comment:3 Changed 10 years ago by awaterland@…

It appears that I needed to run "port clean" instead of just "port remove". It builds fine now. Sorry for the noise, feel free to close this bug now. Thanks.

comment:4 Changed 10 years ago by takanori@…

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.