Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27133 closed defect (duplicate)

kdelibs4 failed to build

Reported by: strassh@… Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: sharky@…, mkae (Marko Käning)
Port: kdelibs4

Description

I tried to install amarok from a totally clean and up to date macport. (I have done "sudo port uninstall --follow-dependents installed" and "sudo port clean --all -f all" just before "sudo port install amarok")

The kdelibs4 build failed. See attachment for a log.

Attachments (2)

main.log.tar.gz (55.4 KB) - added by strassh@… 10 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/main.log
main.log.zip (214.8 KB) - added by strassh@… 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by strassh@…

Attachment: main.log.tar.gz added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/main.log

comment:1 Changed 10 years ago by strassh@…

Cc: strassh@… added

Cc Me!

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: sharky@… added; strassh@… removed
Owner: changed from macports-tickets@… to snc@…

Please remember to cc the maintainers. You do not need to be in cc when you are the reporter.

comment:3 Changed 10 years ago by mkae (Marko Käning)

Well, the attached tar.gz doesn't seem to contain the log. :(

BTW, you should have considered a

  port clean --dist all

as well, to really be sure you have no old garbage on your system.

comment:4 Changed 10 years ago by mkae (Marko Käning)

Cc: mk@… added

Cc Me!

Changed 10 years ago by strassh@…

Attachment: main.log.zip added

comment:5 Changed 10 years ago by mkae (Marko Käning)

I see you're experiencing an issue with phonon!

It looks like you should file a ticket for kdelibs4, since it states:

:info:build /opt/local/bin/cmake -E cmake_progress_report /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdelibs4/work/build/CMakeFiles
:info:build [ 68%] [ 68%] ld: warning: in /Developer/SDKs/MacOSX10.6.sdk/Library/Frameworks//phonon.framework/phonon, missing required architecture x86_64 in file
:info:build Undefined symbols:
:info:build   "Phonon::AudioOutput::AudioOutput(Phonon::Category, QObject*)", referenced from:
:info:build       KFileAudioPreview::KFileAudioPreview(QWidget*, QList<QVariant> const&)in kfileaudiopreview.o

and much more...

comment:6 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: duplicate
Status: newclosed

The issue is he installed software that's colliding with MacPorts. Don't open another ticket; instead, look for the ones that are already available.

Closed as duplicate of #27128.

comment:7 Changed 10 years ago by mkae (Marko Käning)

Sorry, my bad, I see this IS a ticket for kdelibs4. ;-)

Note: See TracTickets for help on using tickets.