Opened 10 years ago

Closed 10 years ago

#27156 closed defect (duplicate)

help2man configure failure - error: perl module Locale::gettext required

Reported by: tim@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: help2man

Description

Using MacPorts with the latest version of xCode installed I tried installing ffmpeg with the following command..

sudo port install ffmpeg

Everything went okay till the end when I got an error message - unfortunately, I did not copy it before exiting the terminal session.

However - I then tried running the "sudo port install ffmpeg" command again, and got the following error message..

173-164-157-129-sfba:~ w3$ sudo port install ffmpeg
Password:
--->  Computing dependencies for help2man
--->  Configuring help2man
Error: Target org.macports.configure returned: configure failure: shell command failed
Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log
Error: Unable to upgrade port: 1
Error: Unable to execute port: upgrade schroedinger failed
To report a bug, see <http://guide.macports.org/#project.tickets>

I tailed "_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg" and got this right after trying the reinstall..

:debug:main No need to upgrade! p5-locale-gettext 1.05_3 >= p5-locale-gettext 1.05_3
:debug:main Starting logging for help2man
:debug:configure couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
:error:configure Unable to upgrade port: 1
:debug:configure upgrade schroedinger failed
    while executing
"macports::_upgrade_mport_deps $mport $target"
    (procedure "mportexec" line 26)
    invoked from within
"mportexec $workername $target"
:error:configure Unable to execute port: upgrade schroedinger failed
:notice:configure To report a bug, see <http://guide.macports.org/#project.tickets>

I also checked "_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man", and got this..

:info:configure configure: error: perl module Locale::gettext required
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.38.2" && ./configure --prefix=/opt/local --enable-nls " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed
:debug:configure Backtrace: configure failure: shell command failed
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for help2man): org.macports.destroot org.macports.configure org.macports.build
:notice:configure Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log

Any idea how I can fix this please?

Thanks.

Attachments (2)

main.log (22.5 KB) - added by tim@… 10 years ago.
_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg
main.2.log (3.6 KB) - added by tim@… 10 years ago.
_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by tim@…

Attachment: main.log added

_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_ffmpeg

Changed 10 years ago by tim@…

Attachment: main.2.log added

_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man

comment:1 Changed 10 years ago by tim@…

I have just included the two logs, in case you need them.

Thanks again.

comment:2 Changed 10 years ago by tim@…

BTW - I am on an Intel iMac, running Mac OS 10.6.4

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: tim@… removed
Keywords: error removed
Port: help2man added
Priority: HighNormal
Summary: Snow Leopard - ffmpeg install errorshelp2man configure failure - error: perl module Locale::gettext required

Please remember to fill in the Port field. You do not need to be in cc when you are the reporter. As per the ticket guidelines, the High priority is reserved for the use of MacPorts team members.

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #21069.

comment:5 in reply to:  4 Changed 10 years ago by tim@…

Resolution: duplicate
Status: closedreopened

Replying to jmr@…:

Duplicate of #21069.

I was asking for help - but none was offered. And this issue is now closed in your opinion?

Thanks for the help. Maybe I asked in the wrong place. At least, if you wouldn't mind, will you direct me to someone, or some place, where I might get advise that will help me resolve this issue?

comment:6 Changed 10 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: reopenedclosed

Re-opening duplicate tickets is not an appropriate way to get help. Trac is for reporting bugs. Use the Macports-Users mailing list for help.

Note: See TracTickets for help on using tickets.