Opened 10 years ago

Closed 10 years ago

#27165 closed defect (fixed)

Cannot install fsharp

Reported by: wbl (Watson Ladd) Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: fsharp

Description (last modified by mf2k (Frank Schima))

When installing fsharp via macports i get the following error message:

>Error: Cannot install fsharp for the arch(s) 'x86_64' because
>Error: its dependency mono only supports the arch(s) 'i386 ppc'.
>Error: Unable to execute port: architecture mismatch

This however seems quite odd. Looking at the main mono site I don't see anything about not supporting 64 bit macs.

Change History (3)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)
Owner: changed from macports-tickets@… to landonf@…
Port: fsharp added; mono removed
Summary: mono port does not support 64 bit macsCannot install fsharp

This is a problem with fsharp, not mono which is 32-bit only.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Mono was reported to not build 64-bit in #20894.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.