Opened 10 years ago

Closed 10 years ago

#27184 closed defect (duplicate)

curl-ca-bundle: curl-7.21.2.tar.bz2 does not exist in /opt/local/var/macports/distfiles/curl

Reported by: wwarren@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc:
Port: curl-ca-bundle

Description (last modified by ryandesign (Ryan Schmidt))

I am logged in a root, and I typed the following:

sh-3.2# port install octave
--->  Computing dependencies for octave
--->  Dependencies to be installed: curl curl-ca-bundle libidn ftgl doxygen coreutils graphviz gd2 xpm ghostscript libpaper urw-fonts xorg-libXaw groff glpk gnuplot aquaterm pdflib hdf5-18 szip pcre qhull cmake qrupdate
--->  Verifying checksum(s) for curl-ca-bundle
Error: Target org.macports.checksum returned: curl-7.21.2.tar.bz2 does not exist in /opt/local/var/macports/distfiles/curl
Log for curl-ca-bundle is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_curl-ca-bundle/main.log
Error: The following dependencies failed to build: curl curl-ca-bundle libidn ftgl doxygen coreutils graphviz gd2 xpm ghostscript libpaper urw-fonts xorg-libXaw groff glpk gnuplot aquaterm pdflib hdf5-18 szip pcre qhull cmake qrupdate
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (2)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to ryandesign@…
Port: curl-ca-bundle added
Status: newassigned
Summary: I can't install octave on snow leopard. I get the following error messagecurl-ca-bundle: curl-7.21.2.tar.bz2 does not exist in /opt/local/var/macports/distfiles/curl

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: assignedclosed

Clean the affected port (in this case, curl-ca-bundle) and try again, making sure to always use "sudo" (or be logged in as root).

sudo port clean curl-ca-bundle
sudo port install curl-ca-bundle

This problem was caused by fetching the port as a normal user without using sudo, then attempting to install it with sudo (or being logged in as root). You should always use sudo (or be logged in as root).

This problem will be fixed in the next version of MacPorts (1.9.2). See #25418, #25937 and others.

Note: See TracTickets for help on using tickets.