Opened 10 years ago

Closed 10 years ago

#27201 closed defect (duplicate)

ffcall @1.10 configuration error - build failure

Reported by: cerfdog69@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.99
Keywords: Cc:
Port: ffcall

Description

I have included the output of "port -d build ffcall". Like I stated in my email to nomaintainer@…, I think it is an autoconf, configure issue, since 10.6.(4) thinks it is x86_64, the compiler identities itself as i686, so all assembly files fail miserably on trying to use ebx, esi, and other registers unavailable in 64 bit mode. It appears ffcall has not had any Intel Mac OS X flavors added to the autoconf files, at least any x86_64-apple-darwin* configuration options. It does support x86_64-suse-linux, which can be used as a model for darwin10.

Attachments (1)

ffcall-build.out (21.1 KB) - added by cerfdog69@… 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by cerfdog69@…

Attachment: ffcall-build.out added

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Milestone: MacPorts 2.0.0
Port: ffcall added; devel/ffcall removed

Email to nomaintainer at macport.org does not actually go to anyone.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #23020.

Note: See TracTickets for help on using tickets.