Opened 10 years ago

Closed 10 years ago

#27412 closed defect (invalid)

gtkspell2 @2.0.16 'failed to load external entity'

Reported by: otto.hasselblad@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: dbevans (David B. Evans)
Port: gtkspell2 gtk-doc

Description (last modified by ryandesign (Ryan Schmidt))

I've tried installing inkscape but gtkspell2 cannot load the file at http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl

i'm running mac os x 10.6.5, xcode 3.2.4. build log attached.

from the log:

:info:build I/O error : Attempt to load network entity http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl
:info:build warning: failed to load external entity "http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl"
:info:build compilation error: file /opt/local/share/gtk-doc/data/gtk-doc.xsl line 10 element import
:info:build xsl:import : unable to load http://docbook.sourceforge.net/release/xsl/current/html/chunk.xsl

Attachments (3)

gtkspell2.log (104.1 KB) - added by otto.hasselblad@… 10 years ago.
build log of gtkspell2
xmlto.log (11.1 KB) - added by otto.hasselblad@… 10 years ago.
xorg-libX11.log (962.0 KB) - added by otto.hasselblad@… 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by otto.hasselblad@…

Attachment: gtkspell2.log added

build log of gtkspell2

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

Please use WikiFormatting.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: devans@… added
Port: gtk-doc added

This is similar to #26151. It shouldn't be trying to download anything in the build phase in the first place.

comment:3 in reply to:  2 Changed 10 years ago by otto.hasselblad@…

I tried upgrading xmlto and received an error similar to #26151 but it was looking for http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl. The xorg-libX11 port was updated overnight and asked for http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl during the build phase. The build subsequently failed.

I'm attaching the log files. Does the problem perhaps have to do with the port docbook-xsl?

Replying to jmr@…:

This is similar to #26151. It shouldn't be trying to download anything in the build phase in the first place.

Changed 10 years ago by otto.hasselblad@…

Attachment: xmlto.log added

Changed 10 years ago by otto.hasselblad@…

Attachment: xorg-libX11.log added

comment:4 Changed 10 years ago by otto.hasselblad@…

I think I found the error... I may have removed catalog.xml from /opt/local/share/xsl/docbook-xsl/ using xmlcatmgr, as instructed to do once docbook-xsl is uninstalled...

######################################################################
# As the flat registry format does not support post-deactivate hooks,
# you will need to ensure that you manually remove the catalog
# entry for this port when you uninstall it.  To do so, run
# "xmlcatmgr remove nextCatalog /opt/local/share/xsl/docbook-xsl/catalog.xml".
######################################################################

I missed the 'un' part of uninstall and removed catalog.xml after I installed docbook-xsl. I discovered this after I reinstalled docbook-xsl with the +doc variant, although it seems +doc is default. xmlto, xorg-libX11 upgraded and gtkspell2 installed.. all without any apparent errors.

Sorry for the confusion, I'm somewhat new to this... Thanks

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.