Opened 10 years ago

Closed 10 years ago

#27457 closed defect (duplicate)

help2man configure failure

Reported by: elke@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: tom@…, ryandesign (Ryan Schmidt), ironforge@…
Port: help2man

Description (last modified by jmroot (Joshua Root))

--->  Computing dependencies for xfig
--->  Dependencies to be installed: Xaw3d xorg-libXp autoconf help2man m4 automake libtool xorg-printproto xpm ghostscript fontconfig freetype jpeg libidn libpaper libpng tiff transfig netpbm jasper xorg-libXi
--->  Configuring help2man
Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Error: Failed to install help2man
Log for help2man is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/main.log
Error: The following dependencies were not installed: Xaw3d xorg-libXp autoconf help2man m4 automake libtool xorg-printproto xpm ghostscript fontconfig freetype jpeg libidn libpaper libpng tiff transfig netpbm jasper xorg-libXi
Error: Status 1 encountered during processing.

Attachments (1)

main.log (12.9 KB) - added by tom@… 10 years ago.
help2man configure log

Download all attachments as: .zip

Change History (8)

comment:1 in reply to:  description Changed 10 years ago by elke@…

Hello, I want to install xfig on a mac with mac os x 10.6.5 and get the following error. It would be nice if you could help me. thanks elke

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: elke@… removed
Description: modified (diff)
Port: help2man added
Summary: problem with help2manhelp2man configure failure

Please remember to preview and use WikiFormatting, and to fill in the Port field. You do not need to be in cc when you are the reporter. Please attach the log file mentioned in the output so we can see what actually happened.

Changed 10 years ago by tom@…

Attachment: main.log added

help2man configure log

comment:3 Changed 10 years ago by tom@…

I've attached the log file, and I've got a solution that worked for me.

The problem was that perl's Locale::gettext was not properly installed. Attempting to install it through ports or cpan also failed, complaining of a missing libintl, or being unable to find the gettext libs.

I was able to install Locale::gettext by obtaining the source, and running

CC='cc -I/opt/local/include -L/opt/local/lib ' perl Makefile.PL

before 'make && make install'

After Locale::gettext was installed, I was able to install help2man through ports.

comment:4 Changed 10 years ago by tom@…

Cc: tom@… added

Cc Me!

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Cc Me!

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ironforge@… added

Has duplicate #27932.

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

OK, so looks like a duplicate of #21069. Feel free to reopen if it's not the same thing (would need to look at the config.log to know).

Note: See TracTickets for help on using tickets.