Opened 8 years ago

Closed 5 years ago

Last modified 5 years ago

#27520 closed defect (fixed)

Qucs architecture is in-compatible with iverilog

Reported by: myschizobuddy@… Owned by: rowue@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: macports@…, dr2chase@…, maehne (Torsten Maehne), cooljeanius (Eric Gallager), anddam (Andrea D'Amore)
Port: qucs

Description (last modified by jmroot (Joshua Root))

Error: Cannot install qucs for the arch(s) 'i386' because
Error: its dependency iverilog is only installed for the arch 'x86_64'
Error: and does not have a universal variant.
Error: Unable to execute port: architecture mismatch

Change History (14)

comment:1 Changed 8 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to rowue@…
Port: qucs added

Please remember to preview and use WikiFormatting, fill in the Port field, and cc the maintainer.

comment:2 Changed 8 years ago by rowue@…

Status: newassigned

Which version of OS X? (10.4, 10.5, 10.6)?

comment:3 Changed 8 years ago by macports@…

This happens to me as well. Probably caused by #23776 which removed the universal variant for iverilog@0.9.3.

OSX 10.6.6, MacPorts 1.9.2

comment:4 Changed 8 years ago by macports@…

Cc: macports@… added

Cc Me!

comment:5 Changed 8 years ago by rowue@…

The problem is, that qt3-mac on which qucs reside (for output) don't work with 64 bit, so we disable 64bit for qucs. And since iverilog does'n work with universal the two versions (64 bit for iverilog and 32 bit for qucs) bite each other ...

Please try:

    port configure iverilog arch=i386
    port build iverilog arch=i386
    port install iverilog arch=i386

to configure, build and install iverilog for i386 before installing qucs. Afterwards try to configure and build qucs.

Kind regards,

Rolf

comment:6 in reply to:  5 Changed 8 years ago by dr2chase@…

Replying to rowue@…

I tried this, and it did not work:

dr2chase:~ dr2chase$ sudo port configure iverilog arch=i386
--->  Computing dependencies for iverilog
--->  Fetching iverilog
--->  Verifying checksum(s) for iverilog
--->  Extracting iverilog
--->  Configuring iverilog
dr2chase:~ dr2chase$ sudo port build iverilog arch=i386
--->  Computing dependencies for iverilog
--->  Building iverilog
dr2chase:~ dr2chase$ sudo port install iverilog arch=i386
Password:
--->  Computing dependencies for iverilog
--->  Fetching archive for iverilog
--->  Attempting to fetch iverilog-0.9.4_0.darwin_10.x86_64.tgz from http://packages.macports.org/iverilog
--->  Staging iverilog into destroot
--->  Installing iverilog @0.9.4_0
--->  Activating iverilog @0.9.4_0
--->  Cleaning iverilog
dr2chase:~ dr2chase$ sudo port install qucs
Error: Cannot install qucs for the arch(s) 'i386' because
Error: its dependency iverilog is only installed for the arch 'x86_64'
Error: and does not have a universal variant.
Error: Unable to execute port: architecture mismatch
To report a bug, see <http://guide.macports.org/#project.tickets>

Output of uname -a:

Darwin dr2chase.local 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386

MacPorts 2.0.1, nothing outdated.

comment:7 in reply to:  5 ; Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: dr2chase@… added

Replying to rowue@…:

port install iverilog arch=i386

"arch=i386" is not meaningful; MacPorts does not have or use a variable called "arch". Perhaps you meant "build_arch":

sudo port install iverilog build_arch=i386

comment:8 Changed 8 years ago by dr2chase@…

The corrected (build_arch=i386 for iverilog) workaround works; I built and installed qucs, and ran it, and also ran a simulation to see if it was basically functional.

comment:9 in reply to:  7 Changed 8 years ago by rowue@…

Replying to ryandesign@…:

Replying to rowue@…:

port install iverilog arch=i386

"arch=i386" is not meaningful; MacPorts does not have or use a variable called "arch". Perhaps you meant "build_arch":

sudo port install iverilog build_arch=i386

O.k. - any suggestions how to put this into the port files?

comment:10 Changed 6 years ago by maehne (Torsten Maehne)

Cc: Torsten.Maehne@… added

Cc Me!

comment:11 Changed 5 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

comment:12 Changed 5 years ago by anddam (Andrea D'Amore)

Cc: and.damore@… added

Please any of the CC'ers confirm that this bug is still actual after three year.

I'm having issue with dependencies and cannot check at the moment.

comment:13 Changed 5 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

No longer depends on qt3 as of r112142.

comment:14 Changed 5 years ago by rowue@…

The problem was, that iverilog only works on i386 (maybe also ppc). (qt3 was an other issue, which was fixed by a switch to qt4 in the latest qucs version). So up to now qucs only supprts i386 and ppc but not x64.

Last edited 5 years ago by rowue@… (previous) (diff)
Note: See TracTickets for help on using tickets.