Opened 10 years ago

Closed 10 years ago

#27525 closed defect (fixed)

exiv2: unable to infer tagged configuration

Reported by: lyle2.0+macports@… Owned by: tcurdt@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: nstanger (Nigel Stanger), jacf01@…, ryandesign (Ryan Schmidt)
Port: exiv2

Description (last modified by ryandesign (Ryan Schmidt))

Doing a "port upgrade outdated", I encounter an error upgrading exiv2. The relevant portion of the error log:

:msg:configure --->  Building exiv2¬
:debug:build build phase started at Wed Dec  1 09:06:14 CST 2010¬
:debug:build Executing org.macports.build (exiv2)¬
:debug:build Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_exiv2/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'¬
:debug:build Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_exiv2/work/exiv2-0.20" && /usr/bin/make -j2 all'¬
:info:build if test "x1" = "x1"; then cd xmpsdk/src && /usr/bin/make xmpsdk; fi;¬
:info:build libtool: compile: unable to infer tagged configuration¬
:info:build libtool: compile: specify a tag with `--tag'¬
:info:build make[1]: *** [XMPMeta.o] Error 1¬
:info:build make[1]: *** Waiting for unfinished jobs....¬
:info:build libtool: compile: unable to infer tagged configuration¬
:info:build libtool: compile: specify a tag with `--tag'¬
:info:build make[1]: *** [XML_Node.o] Error 1¬
:info:build make: *** [xmpsdk] Error 2¬

The error is similar to the one reported in #24820, and I attempted the same fix (sudo port -n upgrade --force libtool && sudo port clean exiv2), but to no avail.

Attachments (1)

exiv2.log (16.9 KB) - added by lyle2.0+macports@… 10 years ago.
Build log

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by lyle2.0+macports@…

Attachment: exiv2.log added

Build log

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to tcurdt@…

comment:3 Changed 10 years ago by nstanger (Nigel Stanger)

Confirmed essentially the same behaviour with recently upgraded version 0.21. The only difference is that the errors above now also include XMPMeta-Parse.o and XMPMeta-GetSet.o (i.e., in addition to the already mentioned XMPMeta.o and XML_Node.o).

comment:4 in reply to:  3 Changed 10 years ago by jacf01@…

Confirmed here too. Same version 0.21.

comment:5 in reply to:  3 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: nigel.stanger@… jacf01@… ryandesign@… added
Summary: exiv2 upgrade to 0.20 failsexiv2: unable to infer tagged configuration

Replying to nigel.stanger@…:

The only difference is that the errors above now also include XMPMeta-Parse.o and XMPMeta-GetSet.o (i.e., in addition to the already mentioned XMPMeta.o and XML_Node.o).

That depends on how many make jobs (-j) you're running simultaneously.

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

"unable to infer tagged configuration" is a message printed by libtool when the compiler used to compile libtool differs from the compiler used to compile the port being compiled now, using libtool. In this case, the difference is that the compiler used to compile libtool was "ccache /usr/bin/g++-4.2" (because the user has "configureccache yes" in their macports.conf, or at least did at the time they built the libtool port), and the compiler now being used to build exiv2 is "/usr/bin/g++-4.2" (because the exiv2 portfile has the line "configure.ccache no" thereby disabling ccache support). This was caused by a combination of r45058 (which made the exiv2 port use the libtool port, because exiv2 0.18's configure script was generated by autoconf 2.61 and the libtool it generated was too old to build universal binaries properly) and r73142 (which disabled the use of ccache with exiv2).

I fixed the problem in r77658 by undoing r45058, since exiv2 0.21's configure script was generated with autoconf 2.67, which is new enough to support universal builds on its own. Additionally, in r77659 I undid r73142 because it builds fine for me with ccache.

Note: See TracTickets for help on using tickets.