Opened 16 years ago

Closed 15 years ago

Last modified 11 years ago

#2753 closed defect (worksforme)

BUG: qt3-mac

Reported by: charley.pritt@… Owned by: leimy@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: olegb@…, markd@…
Port: qt3-mac

Description (last modified by ryandesign (Ryan Schmidt))

attempting to install port qt3-mac
it get to the build/compile and recieve the following errors:

--->  Building qt3-mac with target symlinks src-qmake src-moc sub-src sub-tools
Error: Target com.apple.build returned: shell command "cd "/Users/cpritt/darwinports/dports/aqua/
qt3-mac/work/qt-mac-free-3.3.4" &
& QMAKESPEC='' QTDIR='' DYLD_LIBRARY_PATH="/Users/cpritt/darwinports/dports/aqua/qt3-mac/
work/qt-mac-free-3.3.4/lib" make symlinks
 src-qmake src-moc sub-src sub-tools" returned error 2
Command output:    QApplication::macEventFilter(OpaqueEventHandlerCallRef*, OpaqueEventRef*)' 
   member function declared in class `QApplication'
kernel/qapplication_mac.cpp: In static member function `static void 
   QApplication::flush()':
kernel/qapplication_mac.cpp:2996: error: 'struct QWExtra' has no member named '
   has_dirty_area'
kernel/qapplication_mac.cpp:2998: error: 'struct QWExtra' has no member named '
   has_dirty_area'
kernel/qapplication_mac.cpp:2999: error: 'struct QWExtra' has no member named '
   dirty_area'
kernel/qapplication_mac.cpp:3000: error: 'struct QWExtra' has no member named '
   dirty_area'
kernel/qapplication_mac.cpp:3001: error: `clippedRegion' undeclared (first use 
   this function)
kernel/qapplication_mac.cpp:3013: error: `propagateUpdates' undeclared (first 
   use this function)
kernel/qapplication_mac.cpp:3014: error: parse error before `::' token
kernel/qapplication_mac.cpp: At global scope:
kernel/qapplication_mac.cpp:3023: error: no `bool 
   QApplication::qt_mac_apply_settings()' member function declared in class `
   QApplication'
kernel/qapplication_mac.cpp: In function `void 
   __static_initialization_and_destruction_0(int, int)':
kernel/qapplication_mac.cpp:765: warning: statement with no effect
kernel/qapplication_mac.cpp: At top level:
kernel/qapplication_mac.cpp:530: warning: `void qt_mac_event_release(QWidget*, 
   OpaqueEventRef*&)' defined but not used
{standard input}:600:Ignoring attempt to re-define symbol.
make[1]: *** [.obj/release-shared-mt/qapplication_mac.o] Error 1
make: *** [sub-src] Error 2

what do i do now?

Change History (10)

comment:1 Changed 16 years ago by charley.pritt@…

Component: darwinbuildbase
Keywords: DarwinPorts added; darwinbuild removed
Owner: changed from kevin@… to darwinports-bugs@…
product: darwinbuildDarwinPorts
Version: current1.0

comment:2 Changed 16 years ago by toby@…

Component: basedports

comment:3 Changed 16 years ago by mww@…

Owner: changed from darwinports-bugs@… to leimy@…

assign to maintainer

comment:4 Changed 16 years ago by snu@…

Summary: compile errorBUG: qt3-mac

comment:6 Changed 15 years ago by olegb@…

Cc: olegb@… added

is this still an issue? I cannot reproduce it.

comment:7 Changed 15 years ago by markd@…

Cc: markd@… added

I can't reproduce it either.

comment:8 Changed 15 years ago by markd@…

Resolution: worksforme
Status: newclosed

comment:9 Changed 11 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: DarwinPorts removed
Port: qt4-mac added

comment:10 Changed 11 years ago by ryandesign (Ryan Schmidt)

Port: qt3-mac added; qt4-mac removed
Note: See TracTickets for help on using tickets.