Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#27559 closed defect (worksforme)

Valgrind 3.6.0 crashes on snow leopard

Reported by: VictorEijkhout (Victor Eijkhout) Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: valgrind

Description (last modified by ryandesign (Ryan Schmidt))

%% cc -g read.c              
%% valgrind a.out
valgrind: mmap(0x100000000, 4096) failed in UME (load_segment1).
%% cat read.c 
#include <stdlib.h>
 int main() {
 float *x,y;
 x = (float*)malloc(5*sizeof(float));
 y = x[5];
 return 0;
}

Change History (5)

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Owner: changed from macports-tickets@… to raimue@…
Port: valgrind added

comment:3 Changed 10 years ago by raimue (Rainer Müller)

Resolution: worksforme
Status: newclosed

Sorry, I cannot reproduce this.

Mac OS X 10.6.5, Xcode 3.2.4, valgrind 3.6.0

comment:4 Changed 10 years ago by jdswinbank (John Swinbank)

I see the same problem here on OS X 10.6.6. Running valgrind as superuser seems to fix it, but I'm not sure why that should be necessary.

$ valgrind /usr/bin/true
valgrind: mmap(0x100000000, 36864) failed in UME (load_segment1).
$ sudo valgrind /usr/bin/true
==38475== Memcheck, a memory error detector
==38475== Copyright (C) 2002-2010, and GNU GPL'd, by Julian Seward et al.
==38475== Using Valgrind-3.6.0 and LibVEX; rerun with -h for copyright info
==38475== Command: true

comment:5 Changed 10 years ago by mwoods@…

I see the exact same problem and output as swinbank@…, including the sudo result.

comment:6 Changed 10 years ago by jdswinbank (John Swinbank)

Looks like this is caused by the interaction of Valgrind with Instant Hijack, part of Rogue Amoeba's Airfoil. See https://bugs.kde.org/show_bug.cgi?id=262390#c16 for details (with thanks to "FX").

Note: See TracTickets for help on using tickets.