Opened 10 years ago

Closed 10 years ago

#27565 closed enhancement (duplicate)

set couchdb user's homedir to dbdir

Reported by: jabronson@… Owned by: jyrkiwahlstedt
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: couchdb

Description

patch against current trunk to set couchdb user's homedir to dbdir to match installations on other systems:

Index: Portfile
===================================================================
--- Portfile	(revision 74078)
+++ Portfile	(working copy)
@@ -51,7 +51,7 @@
 
 post-destroot {
     addgroup ${dbgroup}
-    adduser ${dbuser} gid=[existsgroup ${dbgroup}]
+    adduser ${dbuser} gid=[existsgroup ${dbgroup}] home=${dbdir}
     xinstall -m 755 -o ${dbuser} -g ${dbgroup} -d \
 	${destroot}${dbdir} \
 	${destroot}${logdir} \

Change History (4)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: jwa@… removed
Owner: changed from macports-tickets@… to jwa@…

comment:2 Changed 10 years ago by jeff-macports@…

Dupe of #23168

comment:3 in reply to:  2 Changed 10 years ago by jabronson@…

Replying to jeff-macports@…:

Dupe of #23168

oops, i even created that one and didn't remember it (it was almost a year ago). sorry for the dupe.

comment:4 Changed 10 years ago by mf2k (Frank Schima)

Resolution: duplicate
Status: newclosed
Note: See TracTickets for help on using tickets.