Opened 10 years ago

Closed 10 years ago

#27639 closed defect (fixed)

py-m2crypto: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token

Reported by: miguel.erazo@… Owned by: skymoo (Adam Mercer)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: py-m2crypto

Description (last modified by ryandesign (Ryan Schmidt))

I am trying to install m2crypto in my new mac using the command:

sudo port install py-m2crypto

But when I do that I get the following error:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for py-m2crypto is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-m2crypto/main.log

I am attaching this file so you can take a look at it.

My machine is running:

Darwin MacBook-Pro.local 10.5.0 Darwin Kernel Version 10.5.0: Fri Nov  5 23:20:39 PDT 2010; root:xnu-1504.9.17~1/RELEASE_I386 i386

Attachments (1)

main.log (40.7 KB) - added by miguel.erazo@… 10 years ago.
This is the log file from the attempted installation

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by miguel.erazo@…

Attachment: main.log added

This is the log file from the attempted installation

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ram@… added
Description: modified (diff)
Port: py-m2crypto added

py-m2crypto is the python 2.4 version of m2crypto. You may be happier with py26-m2crypto, the python 2.6 version of m2crypto.

I'm Cc'ing the maintainer of py25-m2crypto and py26-m2crypto; maybe he can update py-m2crypto.

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: m2crypto +python Build error - build failurepy-m2crypto: expected '=', ',', ';', 'asm' or '__attribute__' before '*' token

comment:3 Changed 10 years ago by skymoo (Adam Mercer)

Cc: ram@… removed
Owner: changed from macports-tickets@… to ram@…
Status: newassigned

I've updated py-m2crypto to match the python25, python26, and python27 versions in r74394, does that help?

Do you really need the python24 version? This is very old version of python and is not getting any support from upstream?

comment:4 Changed 10 years ago by skymoo (Adam Mercer)

Resolution: fixed
Status: assignedclosed

no response in 5 days, reopen if this is still a problem

Note: See TracTickets for help on using tickets.