Opened 10 years ago

Closed 10 years ago

#27695 closed defect (fixed)

rabbitmq-server @2.1.1 build failure

Reported by: ozawa.tsuyoshi@… Owned by: meyer@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: tonyg@…
Port: rabbitmq-server

Description (last modified by jmroot (Joshua Root))

I tried to build rabbitmq-server @2.1.1, but failed.

My environment is: Mac OS X 10.6.5 Xcode version 3.2.4

I tried the command $ port install rabbitmq-server and its log is as follows :

:msg:main --->  Building rabbitmq-server
:debug:build build phase started at Fri Dec 17 12:47:19 JST 2010
:debug:build Executing org.macports.build (rabbitmq-server)
:debug:build Environment: CPATH='/Users/ozawa/ports/include' CC_PRINT_OPTIONS_FILE='/Users/ozawa/ports/var/macports/build/_Users_ozawa_ports_var_macports_sources_rsync.macports.org_release_ports_net_rabbitmq-server/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/Users/ozawa/ports/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:build Assembled command: 'cd "/Users/ozawa/ports/var/macports/build/_Users_ozawa_ports_var_macports_sources_rsync.macports.org_release_ports_net_rabbitmq-server/work/rabbitmq-server-2.1.1" && /usr/bin/make -j4 all'
:info:build erlc -I include -o ebin -Wall -v +debug_info -Duse_specs -pa ebin src/rabbit_ssl.erl
:info:build erlc -I include -o ebin -Wall -v +debug_info -Duse_specs -pa ebin src/rabbit_types.erl
:info:build src/rabbit_ssl.erl:37: can't find include lib "ssl/src/ssl_int.hrl"
:info:build make: *** [ebin/rabbit_ssl.beam] Error 1
:info:build make: *** Waiting for unfinished jobs....
:info:build shell command " cd "/Users/ozawa/ports/var/macports/build/_Users_ozawa_ports_var_macports_sources_rsync.macports.org_release_ports_net_rabbitmq-server/work/rabbitmq-server-2.1.1" && /usr/bin/make -j4 all " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for rabbitmq-server): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for rabbitmq-server is at: /Users/ozawa/ports/var/macports/logs/_Users_ozawa_ports_var_macports_sources_rsync.macports.org_release_ports_net_rabbitmq-server/main.log

Change History (5)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Cc: tonyg@… added
Owner: changed from macports-tickets@… to meyer@…
Port: rabbitmq-server added

comment:2 in reply to:  1 Changed 10 years ago by ozawa.tsuyoshi@…

Replying to macsforever2000@…:

Sorry, I was wrong the version. Not @2.2.0, but @2.1.1.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Summary: rabbitmq-server @2.2.0 build failurerabbitmq-server @2.1.1 build failure

comment:4 Changed 10 years ago by chris.chamberlin@…

rabbitmq-server seems to now require the ssl variant of erlang: $ port install erlang +ssl $ port install rabbitmq-server

comment:5 Changed 10 years ago by bfulgham@…

Resolution: fixed
Status: newclosed

Erlang now builds with the SSL feature turned on by default. Update to current Erlang to resolve this problem.

Note: See TracTickets for help on using tickets.