Opened 10 years ago

Closed 9 years ago

#27698 closed defect (worksforme)

Cannot retrieve files from lil.fr.distfiles.macports.org

Reported by: jimenez@… Owned by: Ionic (Mihai Moldovan)
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc: nerdling (Jeremy Lavergne)
Port:

Description

Particularly was looking for this file:

http://lil.fr.distfiles.macports.org/libxml2/libxml2-2.7.8.tar.gz

it gets 50% of it and then hangs there forever. I have seen another ticket closed from someone looking for this specific file. Finally he got it from another server.

It is strange because it only happens to files in *that* directory. I can retrieve other sources fast and without any problems.

It has happened to me in one network, I tried another one and it was no accesible form there. Could it be that it is IPv6 enabled. I am working in a iMac w/ Mac OS X 10.5.8 PPC with IPv6 config set to auto for that matter.

This is my first ticket so I hope the info is complete :-)

Thanks in advance.

Juan

Change History (7)

comment:1 Changed 10 years ago by jimenez@…

Cc: jimenez@… added

Cc Me!

comment:2 Changed 10 years ago by wsiegrist@…

Owner: changed from wsiegrist@… to ionic@…

Works for me, but I am assigning to the mirror owner for further investigation.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: ionic@… jimenez@… removed
Version: 1.9.2

comment:4 in reply to:  description Changed 10 years ago by jmroot (Joshua Root)

Replying to jimenez@…:

Could it be that it is IPv6 enabled.

Mirrors says that it is.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

Works for me from .com and .edu IPv6.

Try using curl -O http://lil.fr.distfiles.macports.org/libxml2/libxml2-2.7.8.tar.gz and let us know if it completes for you. If it continues to stall out you may need to do a packet dump and really look at what's happening: my guess is your network is hiccuping.

comment:6 Changed 10 years ago by Ionic (Mihai Moldovan)

Additionally, the options -v and --trace-ascii or --trace may be interesting.

Please upload the full output of: curl -v -O http://lil.fr.distfiles.macports.org/libxml2/libxml2-2.7.8.tar.gz and: curl --trace-ascii tracefile -O http://lil.fr.distfiles.macports.org/libxml2/libxml2-2.7.8.tar.gz (not the output itself here, but the tracefile instead) and curl --trace tracefile -O http://lil.fr.distfiles.macports.org/libxml2/libxml2-2.7.8.tar.gz

I haven't been able to reproduce the problem either, neither via v6, nor via v4.

Please keep in mind, that if IPv6 is enabled, your libcurl may not even try the IPv4, if the IPv6 connection failed, due to changes topology (i.e., if IPv6 is not available in one location.)

If it would be of any help, I could also introduce ip4.lil.fr.distfiles.macports.org and ip6.lil.fr.distfiles.macports.org, which only resolve to the respective IP protocol addresses.

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

Closing due to lack of response.

Note: See TracTickets for help on using tickets.