Opened 10 years ago

Closed 9 years ago

#27714 closed defect (worksforme)

gimp cannot open display:

Reported by: revivo73@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: gimp2

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I'm not sure it it's the right place to post this but I've just installed the gimp on my Mac OS X 10.4.11 PPC (Xcode v2.5) using MacPorts 1.9.2 (Just a note: I had to select the -atlas variant to install py25&py26-numpy).

When I #gimp I get:

(gimp:334): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Cannot open display: 

I've browsed thru other posts at macports.org on this problem but all of them had a display such as ":0.0" but in my case there's no display at all. I've tried these:

setenv DISPLAY :0.0    --> ~/.bashrc
DISPLAY=:0            --> ~/.xinitrc

I suspect they are the right thing to do, however. What should I do now? Thanks.

Change History (5)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

"setenv DISPLAY :0.0" is a command for tcsh, not bash. For bash, you'll want "export DISPLAY=:0.0"

comment:3 Changed 10 years ago by revivo73@…

I've tried it again with that change but still exactly the same error comes up. Have no idea what's missing. Thanks.

comment:4 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…
Port: gimp2 added

Please remember to fill in the Port field and cc the maintainer. The bug tracker is not the place to ask for tech support; try the macports-users mailing list. You probably just don't have X11 running or something.

comment:5 Changed 9 years ago by dbevans (David B. Evans)

Resolution: worksforme
Status: newclosed

Closing as outdated. Works for me with the current version of gimp2.

Note: See TracTickets for help on using tickets.