Opened 9 years ago

Closed 8 years ago

#27805 closed defect (fixed)

openconnect @2.25_1 gconf is not necessary to build the port

Reported by: chris.walter@… Owned by: Mathias.Laurin+macports@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: openconnect

Description

Although gconf is not necessary to build openconnect (it is necessary if you want to support network-manager in gnome) is is included in the dependencies.

This causes a lot of gnome libraries to be brought in unnecessarily which for many users in unneeded. I confirmed that if you remove it from the port file openconnect still works fine.

From the web page(http://www.infradead.org/openconnect/):

"For building the NetworkManager support, you will also need: GTK GConf"

Could this be put in a variant (if network-manager is even possible in macports) or removed?

Thanks for this port!

Change History (7)

comment:1 Changed 9 years ago by jmroot (Joshua Root)

Cc: Mathias.Laurin+macports@… removed
Owner: changed from macports-tickets@… to Mathias.Laurin+macports@…
Port: openconnect added

Please remember to fill in the Port field.

comment:2 Changed 9 years ago by Mathias.Laurin+macports@…

Fixed with update to openconnect @2.26, Ticket #27809 - thank you for reporting.

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

I see lines in the Makefile like:

GTK_CFLAGS += $(shell pkg-config --cflags gtk+-x11-2.0 gthread-2.0 2>/dev/null)
...
GCONF_CFLAGS += $(shell pkg-config --cflags gconf-2.0 2>/dev/null)

This means openconnect needs a build-time dependency on port:pkgconfig, and that openconnect uses gconf and gtk2 if present. Therefore, you can't simply delete the gconf dependency from openconnect as you propose, because openconnect will still make use of gconf if the user happens to have installed it before openconnect. The possible courses of action are to either leave the gconf dependency in place (and add a pkgconfig dependency), or, if you desire to delete it, then you must find a way to inform openconnect that it may not use gconf even if it is already present (and, optionally, add a variant to then re-enable gconf support).

Note that we generally prefer ports in MacPorts to be as fully-featured as possible; if we obey that rule of thumb, then we would close this ticket with no changes to the port.

comment:4 Changed 9 years ago by Mathias.Laurin+macports@…

OK, I understand. But I am not interested in installing either X11 nor gnome via macports, so that I would not be able to test the port. I also understand that it would not be acceptable to patch all of the gconf and gtk dependencies out, unless it is done in a variant. I must shy away from maintaining this port. Please change it to nomaintainer.

comment:5 Changed 9 years ago by mf2k (Frank Schima)

Changed to nomaintainer in r76787.

comment:6 Changed 9 years ago by dwmw2@…

The NetworkManager authentication dialog has now been moved out of OpenConnect and into the NetworkManager-openconnect package where it belongs.

It might have been useful to bring this discussion to the attention of the upstream maintainer of OpenConnect at the time. You could always have simply used 'make openconnect' instead of just 'make', to avoid building the auth-dialog even if GConf and the other dependencies were present.

I could have confirmed for you that openconnect *itself* does not use GConf at all.

comment:7 Changed 8 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Dealt with by updating the port; see #31237.

Note: See TracTickets for help on using tickets.