Opened 10 years ago

Closed 10 years ago

#27839 closed defect (duplicate)

gimp-app fails to build due to corrupted PCH cache

Reported by: david.hislop.1@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: dbevans (David B. Evans)
Port: gimp-app

Description (last modified by ryandesign (Ryan Schmidt))

gimp-app fails to build after sudo port selfupdate with error:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for gimp-app is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/main.log
Error: Unable to upgrade port: 1

Tried some of the suggestions in #26747, i.e.:

sudo port clean --all gimp-app
sudo port selfupdate
sudo port sync
sudo port upgrade --force installed

main.log (full log attached) contains at the end:

:info:build ** BUILD FAILED **:info:build 
:info:build 
:info:build The following build commands failed:
:info:build ScriptExec:
:info:build     CompileC build/ScriptExec.build/Deployment/ScriptExec.build/Objects-normal/x86_64/main.o /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec/main.c normal x86_64 c com.apple.compilers.gcc.4_2
:info:build (1 failure)
:info:build 
:info:build shell command "cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_gimp-app/work/ScriptExec" && /usr/bin/xcodebuild  -alltargets -configuration Deployment build OBJROOT=build/ SYMROOT=build/ MACOSX_DEPLOYMENT_TARGET=10.6 ARCHS=x86_64 SDKROOT="" " returned error 1
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:build Warning: the following items did not execute (for gimp-app): org.macports.destroot org.macports.build

Attachments (2)

main.log (11.3 KB) - added by david.hislop.1@… 10 years ago.
gimp-app main.log
main.2.log (187.6 KB) - added by david.hislop.1@… 10 years ago.
gimp-app main.log after "sudo port install gimp-app" only

Download all attachments as: .zip

Change History (5)

Changed 10 years ago by david.hislop.1@…

Attachment: main.log added

gimp-app main.log

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: gimp-app added

In future, please use WikiFormatting and fill in the Port field.

Please "sudo port clean gimp-app" and try installing again, and attach the main.log immediately after doing so. The main.log you attached here contains lines "Skipping completed" and is therefore incomplete and doesn't tell us everything that happened.

Changed 10 years ago by david.hislop.1@…

Attachment: main.2.log added

gimp-app main.log after "sudo port install gimp-app" only

comment:2 Changed 10 years ago by david.hislop.1@…

I executed

sudo port clean gimp-app
sudo port install gimp-app

with the same results. New main.log attached.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Cc: devans@… added
Resolution: duplicate
Status: newclosed
Summary: gimp-app fails to buildgimp-app fails to build due to corrupted PCH cache
:info:build cc1: error: /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Caches-/com.apple.Xcode.0/SharedPrecompiledHeaders/ScriptExec_Prefix-fjqslffpxdgvupftqlldkqzqbvow/ScriptExec_Prefix.pch: No such file or directory
:info:build cc1: error: one or more PCH files were found, but they were invalid

It's this same old corrupted PCH cache thing that I've never been able to reproduce. Duplicate of #26952.

Note: See TracTickets for help on using tickets.