Opened 10 years ago

Closed 10 years ago

#27848 closed update (fixed)

Gallery version bump, license added

Reported by: chad@… Owned by: ckieffer@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: mfisher@…, ryandesign (Ryan Schmidt)
Port: gallery

Description

Hello,

Attached is a version bump to Gallery 2.3.1. Also included Gallery's license, GPL v2.

Please apply when possible.

Thanks, Chad

Attachments (2)

Portfile-gallery-2.3.1.patch (409 bytes) - added by chad@… 10 years ago.
Patch for 2.3.1 version bump
gallery-ryandesign.diff (2.3 KB) - added by ryandesign (Ryan Schmidt) 10 years ago.
proposed patch

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by chad@…

Patch for 2.3.1 version bump

Changed 10 years ago by ryandesign (Ryan Schmidt)

Attachment: gallery-ryandesign.diff added

proposed patch

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: mfisher@… ryandesign@… added
Owner: changed from macports-tickets@… to ckieffer@…

Some comments:

  • Please Cc the maintainer of the port you're filing a ticket about (unless you are the maintainer, using a different email address? If so, please indicate)
  • Please search the issue tracker for existing issues; this was already filed as #24782 but I'll mark that a duplicate of this since we're discussing it here and this is more up to date
  • You neglected to update the checksums

I attached a new proposed patch which does the following:

  • updates to 2.3.1
  • adds license info
  • indicates this does not install any architecture-specific files
  • removes php4 and apache 1 support as those are obsolete
  • uses php5-web dependency
  • uses php5-mysql or php5-postgresql dependencies, thus simplifying those database variants
  • removes pkgconfig dependency; I couldn't find any evidence that pkgconfig gets used
  • simplified destroot

Maintainer, may we commit this?

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Maintainer says yes this is him, and yes we may commit it. So I did in r74813.

Note: See TracTickets for help on using tickets.