Opened 10 years ago

Closed 10 years ago

#27863 closed defect (fixed)

latexmk checksum error

Reported by: tlhayward@… Owned by: vinc17@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: drkp (Dan Ports)
Port: latexmk

Description (last modified by jmroot (Joshua Root))

When installing latexmk there is a checksum error, as follows:

admin [/opt/local/var/macports/registry/portfiles/texlive-latex]> sudo port clean --all latexmk
--->  Cleaning latexmk
admin [/opt/local/var/macports/registry/portfiles/texlive-latex]> sudo port install latexmk
--->  Computing dependencies for latexmk
--->  Fetching latexmk
--->  Attempting to fetch latexmk.zip from http://www.ctan.org/get/support
--->  Verifying checksum(s) for latexmk
Error: Checksum (md5) mismatch for latexmk.zip
Error: Checksum (sha1) mismatch for latexmk.zip
Error: Checksum (rmd160) mismatch for latexmk.zip
Error: Target org.macports.checksum returned: Unable to verify file checksums
Log for latexmk is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_latexmk/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (11)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Description: modified (diff)
Owner: changed from macports-tickets@… to vinc17@…

Please remember to preview and use WikiFormatting, and to cc the maintainer.

comment:2 Changed 10 years ago by vinc17@…

Resolution: worksforme
Status: newclosed

No problems on my machine (I've just tried). The logs you provided show that nothing has been fetched. You may have outdated files (possibly from a previous download failure). Please clean with

sudo port clean -v --all latexmk

and try again. If this still doesn't work, you should provide the logs showing the fetch.

comment:3 Changed 10 years ago by jmroot (Joshua Root)

The output in the description isn't verbose, but it does show the distfile being fetched.

comment:4 Changed 10 years ago by tlhayward@…

Resolution: worksforme
Status: closedreopened

Thank you for your advice. Here is the verbose output, followed by the log file.

I have installed many MacPorts packages without problems; latexmk is the only package for which I see the checksum error.

I have also checked that there are no other copies of latexmk.zip anywhere on my system.

admin [~]> sudo port clean -v --all latexmk
Password:
--->  Cleaning latexmk
admin [~]> sudo port -v install latexmk
--->  Computing dependencies for latexmk.
--->  Fetching latexmk
--->  latexmk.zip doesn't seem to exist in /opt/local/var/macports/distfiles/latexmk/4.18
--->  Attempting to fetch latexmk.zip from http://www.ctan.org/get/support
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  229k  100  229k    0     0  51617      0  0:00:04  0:00:04 --:--:--  117k
--->  Verifying checksum(s) for latexmk
--->  Checksumming latexmk.zip
Error: Checksum (md5) mismatch for latexmk.zip
Portfile checksum: latexmk.zip md5 12a2c3ea16d4190895e483795f566ae7
Distfile checksum: latexmk.zip md5 8c6b5b6517d896b42b723b98556f504d
Error: Checksum (sha1) mismatch for latexmk.zip
Portfile checksum: latexmk.zip sha1 7694aaa764adc8ec1c0628fe2ecaad6821fb0b30
Distfile checksum: latexmk.zip sha1 367638eaf00b055c8cbe6bb3f8a2b0e2e90566f5
Error: Checksum (rmd160) mismatch for latexmk.zip
Portfile checksum: latexmk.zip rmd160 ba472b5f14445b9625d34e6bf78f88cfe889a9bf
Distfile checksum: latexmk.zip rmd160 dc7b1364fd93538344c996d242f4f2bfc26b1577
The correct checksum line may be:
checksums           md5     8c6b5b6517d896b42b723b98556f504d \
                    sha1    367638eaf00b055c8cbe6bb3f8a2b0e2e90566f5 \
                    rmd160  dc7b1364fd93538344c996d242f4f2bfc26b1577
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for latexmk): org.macports.activate org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Log for latexmk is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_latexmk/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

The log file:

:debug:main Executing org.macports.main (latexmk)
:msg:main --->  Fetching latexmk
:debug:fetch fetch phase started at Mon Jan 10 13:41:42 CLST 2011
:debug:fetch Executing org.macports.fetch (latexmk)
:info:fetch --->  latexmk.zip doesn't seem to exist in /opt/local/var/macports/distfiles/latexmk/4.18
:debug:fetch Pinging www.ctan.org...
:debug:fetch Pinging distfiles.macports.org...
:debug:fetch Pinging aarnet.au.distfiles.macports.org...
:debug:fetch Pinging cjj.kr.distfiles.macports.org...
:debug:fetch Pinging lil.fr.distfiles.macports.org...
:debug:fetch Pinging sea.us.distfiles.macports.org...
:debug:fetch Pinging ykf.ca.distfiles.macports.org...
:debug:fetch www.ctan.org ping time is 10000
:debug:fetch distfiles.macports.org ping time is 10000
:debug:fetch aarnet.au.distfiles.macports.org ping time is 10000
:debug:fetch cjj.kr.distfiles.macports.org ping time is 10000
:debug:fetch lil.fr.distfiles.macports.org ping time is 10000
:debug:fetch sea.us.distfiles.macports.org ping time is 10000
:debug:fetch ykf.ca.distfiles.macports.org ping time is 10000
:msg:fetch --->  Attempting to fetch latexmk.zip from http://www.ctan.org/get/support
:msg:fetch --->  Verifying checksum(s) for latexmk
:debug:checksum checksum phase started at Mon Jan 10 13:41:50 CLST 2011
:debug:checksum Executing org.macports.checksum (latexmk)
:info:checksum --->  Checksumming latexmk.zip
:error:checksum Checksum (md5) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip md5 12a2c3ea16d4190895e483795f566ae7
:info:checksum Distfile checksum: latexmk.zip md5 8c6b5b6517d896b42b723b98556f504d
:error:checksum Checksum (sha1) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip sha1 7694aaa764adc8ec1c0628fe2ecaad6821fb0b30
:info:checksum Distfile checksum: latexmk.zip sha1 367638eaf00b055c8cbe6bb3f8a2b0e2e90566f5
:error:checksum Checksum (rmd160) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip rmd160 ba472b5f14445b9625d34e6bf78f88cfe889a9bf
:info:checksum Distfile checksum: latexmk.zip rmd160 dc7b1364fd93538344c996d242f4f2bfc26b1577
:info:checksum The correct checksum line may be:
:info:checksum checksums           md5     8c6b5b6517d896b42b723b98556f504d \

comment:5 Changed 10 years ago by j.cope@…

This issue affects me too, though my Portfile checksums match tlhayward's Distfile checksums.

Verbose output from 'sudo port -v upgrade latexmk':

--->  Computing dependencies for latexmk.
--->  Fetching latexmk
--->  latexmk.zip doesn't seem to exist in /opt/local/var/macports/distfiles/latexmk/4.21
--->  Attempting to fetch latexmk.zip from http://www.ctan.org/get/support
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  230k  100  230k    0     0   209k      0  0:00:01  0:00:01 --:--:--  209k
--->  Verifying checksum(s) for latexmk
--->  Checksumming latexmk.zip
Error: Checksum (md5) mismatch for latexmk.zip
Portfile checksum: latexmk.zip md5 8c6b5b6517d896b42b723b98556f504d
Distfile checksum: latexmk.zip md5 12f916ba257967abea305d317c3cb840
Error: Checksum (sha1) mismatch for latexmk.zip
Portfile checksum: latexmk.zip sha1 367638eaf00b055c8cbe6bb3f8a2b0e2e90566f5
Distfile checksum: latexmk.zip sha1 6fdf7331d2d0c3f9dca58a1bbf459eda94c29308
Error: Checksum (rmd160) mismatch for latexmk.zip
Portfile checksum: latexmk.zip rmd160 dc7b1364fd93538344c996d242f4f2bfc26b1577
Distfile checksum: latexmk.zip rmd160 7b4322ab339082077b7630dc4d16aa7853e9cbb0
The correct checksum line may be:
checksums           md5     12f916ba257967abea305d317c3cb840 \
                    sha1    6fdf7331d2d0c3f9dca58a1bbf459eda94c29308 \
                    rmd160  7b4322ab339082077b7630dc4d16aa7853e9cbb0
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for latexmk): org.macports.destroot org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build
Log for latexmk is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_latexmk/main.log
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

Log file:

version:1
:msg:main --->  Computing dependencies for latexmk:info:main .:debug:main Searching for dependency: unzip
:debug:main Didn't find receipt, going to depspec regex for: unzip
:debug:main Found Dependency: path: /usr/bin filename: unzip regex: ^unzip$
:debug:main Found Dependency: path: /usr/bin filename: unzip regex: ^unzip$
:debug:main Searching for dependency: texlive-latex
:debug:main Found Dependency: receipt exists for texlive-latex
:msg:main 
:debug:main Executing org.macports.main (latexmk)
:msg:main --->  Fetching latexmk
:debug:fetch fetch phase started at Fri Jan 14 11:13:09 GMT 2011
:debug:fetch Executing org.macports.fetch (latexmk)
:info:fetch --->  latexmk.zip doesn't seem to exist in /opt/local/var/macports/distfiles/latexmk/4.21
:debug:fetch Pinging www.ctan.org...
:debug:fetch Pinging distfiles.macports.org...
:debug:fetch Pinging aarnet.au.distfiles.macports.org...
:debug:fetch Pinging cjj.kr.distfiles.macports.org...
:debug:fetch Pinging lil.fr.distfiles.macports.org...
:debug:fetch Pinging sea.us.distfiles.macports.org...
:debug:fetch Pinging ykf.ca.distfiles.macports.org...
:debug:fetch www.ctan.org ping time is 10000
:debug:fetch distfiles.macports.org ping time is 10000
:debug:fetch aarnet.au.distfiles.macports.org ping time is 10000
:debug:fetch cjj.kr.distfiles.macports.org ping time is 10000
:debug:fetch lil.fr.distfiles.macports.org ping time is 10000
:debug:fetch sea.us.distfiles.macports.org ping time is 10000
:debug:fetch ykf.ca.distfiles.macports.org ping time is 10000
:msg:fetch --->  Attempting to fetch latexmk.zip from http://www.ctan.org/get/support
:msg:fetch --->  Verifying checksum(s) for latexmk
:debug:checksum checksum phase started at Fri Jan 14 11:13:13 GMT 2011
:debug:checksum Executing org.macports.checksum (latexmk)
:info:checksum --->  Checksumming latexmk.zip
:error:checksum Checksum (md5) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip md5 8c6b5b6517d896b42b723b98556f504d
:info:checksum Distfile checksum: latexmk.zip md5 12f916ba257967abea305d317c3cb840
:error:checksum Checksum (sha1) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip sha1 367638eaf00b055c8cbe6bb3f8a2b0e2e90566f5
:info:checksum Distfile checksum: latexmk.zip sha1 6fdf7331d2d0c3f9dca58a1bbf459eda94c29308
:error:checksum Checksum (rmd160) mismatch for latexmk.zip
:info:checksum Portfile checksum: latexmk.zip rmd160 dc7b1364fd93538344c996d242f4f2bfc26b1577
:info:checksum Distfile checksum: latexmk.zip rmd160 7b4322ab339082077b7630dc4d16aa7853e9cbb0
:info:checksum The correct checksum line may be:
:info:checksum checksums           md5     12f916ba257967abea305d317c3cb840 \
                    sha1    6fdf7331d2d0c3f9dca58a1bbf459eda94c29308 \
                    rmd160  7b4322ab339082077b7630dc4d16aa7853e9cbb0
:error:checksum Target org.macports.checksum returned: Unable to verify file checksums
:debug:checksum Backtrace: Unable to verify file checksums
    while executing
"$procedure $targetname"
:info:checksum Warning: the following items did not execute (for latexmk): org.macports.destroot org.macports.checksum org.macports.extract org.macports.patch org.macports.configure org.macports.build
:notice:checksum Log for latexmk is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_tex_latexmk/main.log

comment:6 Changed 10 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:7 Changed 10 years ago by drkp (Dan Ports)

I'm getting this too (on only one of my machines). It looks like the unversioned distfile on CTAN got updated -- 4.22b is out -- causing a checksum failure.

It succeeds on my other machine because it had a faster ping time to one of the distfiles mirrors and fetched it from there instead. That one does match the portfile's checksum, of course. That's probably why it works for you.

I found versioned distfiles at e.g. http://www.phys.psu.edu/~collins/software/latexmk-jcc/latexmk-421.zip so it would probably be better to use those instead.

comment:8 in reply to:  7 Changed 10 years ago by vinc17@…

Resolution: fixed
Status: reopenedclosed

Replying to dports@…:

I'm getting this too (on only one of my machines). It looks like the unversioned distfile on CTAN got updated -- 4.22b is out -- causing a checksum failure.

4.22c is out. I've updated the Portfile.

I found versioned distfiles at e.g. http://www.phys.psu.edu/~collins/software/latexmk-jcc/latexmk-421.zip so it would probably be better to use those instead.

The problem is that the author's site is generally out-of-date.

comment:9 Changed 10 years ago by mike-savory

Resolution: fixed
Status: closedreopened

Looks to have broken again...

$ sudo port upgrade latexmk ---> Computing dependencies for latexmk ---> Fetching latexmk ---> Attempting to fetch latexmk.zip from http://distfiles.macports.org/latexmk/4.22c ---> Attempting to fetch latexmk.zip from http://www.ctan.org/get/support ---> Verifying checksum(s) for latexmk

DEBUG: Executing org.macports.checksum (latexmk) ---> Checksumming latexmk.zip Error: Checksum (md5) mismatch for latexmk.zip Portfile checksum: latexmk.zip md5 ea9b23d7d6f63018f8ee90f57e31cf10 Distfile checksum: latexmk.zip md5 fecbaa60bb9e8da78227622e09a21329 Error: Checksum (sha1) mismatch for latexmk.zip Portfile checksum: latexmk.zip sha1 a22618375957c240d06d2ed67ef2507c46df18c0 Distfile checksum: latexmk.zip sha1 232a0096f341a9d9712678ab241aebfcc29af9a9 Error: Checksum (rmd160) mismatch for latexmk.zip Portfile checksum: latexmk.zip rmd160 c1a7f7296ff459d41f7f16a9a9f5ccffebf355fa Distfile checksum: latexmk.zip rmd160 d371abb61bd4fa3adfb59fed891bc8ce07b73156 The correct checksum line may be: checksums md5 fecbaa60bb9e8da78227622e09a21329 \

sha1 232a0096f341a9d9712678ab241aebfcc29af9a9 \ rmd160 d371abb61bd4fa3adfb59fed891bc8ce07b73156

comment:10 Changed 10 years ago by jmroot (Joshua Root)

I can't even fetch it; http://www.ctan.org/get/support gives a 503.

comment:11 Changed 10 years ago by vinc17@…

Resolution: fixed
Status: reopenedclosed

Fixed in r75554. ctan.org is currently down, but I no longer use CTAN. This should solve the checksum problem (I just hope that the author's website will now be up-to-date).

Note: See TracTickets for help on using tickets.