Opened 10 years ago

Closed 10 years ago

#27865 closed submission (fixed)

skrooge: new port

Reported by: stephane@… Owned by: mkae (Marko Käning)
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: pixilla (Bradley Giesbrecht), guillaume.debure@…
Port: skrooge

Description (last modified by mkae (Marko Käning))

'The addition of Skrooge has been requested by an end user running Skrooge in a virtual machine.

Attachments (3)

Portfile (1.1 KB) - added by stephane@… 10 years ago.
Proposal for a Portfile (sorry, I am not an expect)
Portfile.2 (1.0 KB) - added by mkae (Marko Käning) 10 years ago.
I couldn't resist to adapt the portfile for skrooge-devel being build from the svn version. (When running it, however, I see only one window with almost no content, no active button, no functionality. So, I guess there is still some research necessary as to what's going on here. BTW, I left kde4-runtime out of the dependencies, since I didn't need it for kmymoney4(-devel) either.)
skrooge-devel.png (59.5 KB) - added by mkae (Marko Käning) 10 years ago.
Here's the window appearing on my screen when starting skrooge using "/opt/local/Applications/KDE4/skrooge.app/Contents/MacOS/skrooge"

Download all attachments as: .zip

Change History (51)

Changed 10 years ago by stephane@…

Attachment: Portfile added

Proposal for a Portfile (sorry, I am not an expect)

comment:1 Changed 10 years ago by stephane@…

Cc: stephane@… added

Cc Me!

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: mk@… brad@… added; stephane@… removed
Port: skrooge added
Version: 1.9.2

You don't need to be in cc when you are the reporter. Have Marko and Brad agreed to maintain this? The name of the port alone is not an adequate description.

comment:3 Changed 10 years ago by stephane@…

Hi,

Tank you for your answer. I don't know if Marko and Brad are supporting this request. I just tried to follow the process to do request described here: http://guide.macports.org/#project.contributing.new Sorry, if I did an error.

comment:4 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane,

it looks like you have used a Portfile of ours as a template for your Portfile. :-) Me and Brad appear as maintainers, which is probably not intended by you... and should be mended.

(But I am willing to give this port a try.)

Greets, Marko

comment:5 Changed 10 years ago by mkae (Marko Käning)

I'm wondering whether you actually tried to install the port... Here on my end it doesn't even download the tar.bz2. :-( http://skrooge.org/files always returns 404!

comment:6 in reply to:  description Changed 10 years ago by pixilla (Bradley Giesbrecht)

Stephane: Looks like you are one of the developers of Skrooge. There is a file download issue with your site. Try using curl to download your file and you get a "page not found" error page. I'm guessing your Drupal site is testing the User Agent probably with Javascript to start the download.

$ curl http://skrooge.org/files/skrooge-0.8.0.tar.bz2

Are the Skrooge sources available anywhere else?

--
Brad

comment:7 Changed 10 years ago by ryandesign (Ryan Schmidt)

Summary: To add Skroogeskrooge: new port

comment:8 Changed 10 years ago by stephane@…

Hi,

You are right, I used an existing Portfile as template.

I don't understand why curl doesn't work. I will analyze. I will take you informed.

Source is available in KDE's svn too. (http://websvn.kde.org/trunk/extragear/office/skrooge)

Thank you for your help.

comment:9 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Stephane: Is there an svn revision associated with your 0.8.0 release?

I can set up your Portfile to use svn but we should lock it to a revision. I suggest we name the port skrooge-devel and when you have your non-gui-brower downloads of your release version working we can create a new skrooge port and keep the skrooge-devel version using svn.

comment:10 Changed 10 years ago by stephane@…

Hi Brad,

The svn version of Skrooge 0.8.0 is 1204256. I like your proposal.

I am still analyzing the curl issue...

Thank you again.

comment:11 Changed 10 years ago by mkae (Marko Käning)

Hi Brad,

you could be re-using kmymoney4-devel's portfile. That has everything in place for SVN already.

Have fun!

Greets, Marko

Changed 10 years ago by mkae (Marko Käning)

Attachment: Portfile.2 added

I couldn't resist to adapt the portfile for skrooge-devel being build from the svn version. (When running it, however, I see only one window with almost no content, no active button, no functionality. So, I guess there is still some research necessary as to what's going on here. BTW, I left kde4-runtime out of the dependencies, since I didn't need it for kmymoney4(-devel) either.)

Changed 10 years ago by mkae (Marko Käning)

Attachment: skrooge-devel.png added

Here's the window appearing on my screen when starting skrooge using "/opt/local/Applications/KDE4/skrooge.app/Contents/MacOS/skrooge"

comment:12 Changed 10 years ago by mkae (Marko Käning)

Description: modified (diff)

Just for the sake of completeness: I did install skrooge with kde4-runtime installed and without it!

But it didn't make a difference, both installations show the same dysfunctional window.

(BTW, actually the window looked a bit different at the first start. There was a little window inside which I erroneously dragged out of the main window. I can't remember whether I closed it, but after that it never appeared again.)

Cool to have you, Stephane, as the project's maintainer on board, so I guess it will be much easier to diagnose what's going on here''

comment:13 Changed 10 years ago by mkae (Marko Käning)

Owner: changed from macports-tickets@… to mk@…

comment:14 Changed 10 years ago by mkae (Marko Käning)

Cc: mk@… removed

comment:15 Changed 10 years ago by mkae (Marko Käning)

BTW, I have NOT YET committed the Portfile to MacPorts, due to the experienced problems. Please let me know how it works out on your end!

comment:16 Changed 10 years ago by mkae (Marko Käning)

BTW, Stephane, what does it mean that you run skrooge in a VM? Do you run a Linux VM on your MacOSX to be able to run skrooge? Or did you manage to get skrooge to build natively on your Apple?

comment:17 Changed 10 years ago by stephane@…

Hi,

I don't have an Apple. I have a PC on Kubuntu. I am the main developer of Skrooge and one user using Skrooge in a linux virtual machine on his MacOSX asked my the question if I planed to add Skrooge in MacPorts.

So, I discovered what is MacPorts and I opened this request. This is not for me, this is for MacOS users of Skrooge.

comment:18 Changed 10 years ago by mkae (Marko Käning)

OK, in that case I guess your user has to get involved in testing this issue. I figure you pointed your user to this ticket by now!

It's great that YOU got involved. :-)

I wonder whether you can already tell from the attached image what might have gone wrong here on my end. It looks like the app doesn't build its interface properly.

comment:19 Changed 10 years ago by stephane@…

Hi,

The user is informed. I asked him to test it.

You must know that in skrooge, all functions are plugins. So, if the GUI is empty like in your capture, it means that plugins are not registered. To do the registration, you have to launch the KDE tool named kbuildsycoca4.

On linux, this registration is done automatically after the installation of Skrooge.

comment:20 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane,

thanks for the kbuildsycocoa4 hint! :-)

Now I get it to run!!'''

There are still crashes every now and then, but I think it is now fit enough to be released so that other users can report back their findings. Stephane, I guess I'll have to direct them to kde.bugs.org to let you know about these issues.

I had already a few such crashes here, but at least it works to some degree. I was able to create an account, make use of the nice history feature even. :-)

Unfortunately b.k.o's bugtracker is unable to report errors found for more than one operating system. In case a bug is present on Mac OS X and also on Linux one would have to use Linux and just write as a textual comment that it also occurs on Mac OS X.

Nice work!

I'll close this thread as soon as I committed the new skrooge port to MacPorts.

Keep me posted about your download issue and about SVN versions worth updating the devel port to. (For kmymoney4-devel I actually regularly check its SVN repo for a new version and update the Portfile accordingly to stay as close as possible.)

Greets, Marko

comment:21 Changed 10 years ago by mkae (Marko Käning)

Resolution: fixed
Status: newclosed

Port created in r74923.

comment:22 Changed 10 years ago by pixilla (Bradley Giesbrecht)

Stephane, Any luck fixing curl/http downloads on your source server?

comment:23 Changed 10 years ago by mkae (Marko Käning)

Resolution: fixed
Status: closedreopened

Stephane, I meant to ask you why it is actually necessary to have kdebase4-runtime as dependency. I omitted it at the moment from the port file since I found that it runs also without it. But - to tell the truth - there was a difference between the two installtions with and without the runtime libs: the one without it didn't know the currency USD and complained about it whereas the other didn't. :-)

I'll include the dep if it is really needed, of course, Marko

Since the actual skrooge port does still not exist, I keep this ticket open until the curl issue is fixed. OK, Brad?

comment:24 Changed 10 years ago by stephane@…

Hi,

Skrooge needs KDE4 libraries, qca and sqlite3. So, I think that you have to add a dependency on: port:kdelibs4 port:sqlite3 port:qca-ossl port:oxygen-icons

The tester is testing it but seems to have issues. I take you informed.

We are still analysing curl issue too.

comment:25 Changed 10 years ago by mkae (Marko Käning)

Okay. I change the deps accordingly in r74950.

comment:26 Changed 10 years ago by mkae (Marko Käning)

r74951 removes explicit dep to sqlite3, since that's already done via kdelibs4->qt4-mac!

comment:27 Changed 10 years ago by mkae (Marko Käning)

Well, I rebuilt a new MacPorts installation from scratch to verify that the current portfile does not miss anything. All is fine, as far as I can see, except I see messages like these:

[ MP-clean-slate ] :opt marko$ /opt/clean-slate/Applications/KDE4/skrooge.app/Contents/MacOS/skrooge kdeinit4: (klauncher /opt/clean-slate/lib/kde4/libexec/klauncher) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or directory
kdeinit4: (kded4 /opt/clean-slate/Applications/KDE4/kded4.app/Contents/MacOS/kded4) Pipe closed unexpectedlykdeinit4: Pipe closed unexpectedly: No such file or directory
kdeinit4: Communication error with launcher. Exiting!

but they don't seem to do any harm so far to the application (at least not with what I played around up to now), in contrast to problems with kmymoney4(-devel) and other KDE4 applications (see eg. #25178 and #27555).

comment:28 Changed 10 years ago by stephane@…

Hi,

An user is testing Skrooge and found a problem, corrected now. So, could you update the portfile to point on svn version 1215026 ?

We are progressing ! Thank you.

comment:29 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane, committed as r75247 !

comment:30 Changed 10 years ago by mkae (Marko Käning)

Any progress concerning the download issue?

comment:31 Changed 10 years ago by stephane@…

Hi mk,

Thank you, the MacOS version is better but we still have an issue with the merged global menu. I delivered a modification for test.

Could update the portfile to point on svn version 1215845 ?

We are still analyzing the curl issue.

comment:32 Changed 10 years ago by mkae (Marko Käning)

OK. Updated portfile committed as r75284 !

comment:33 Changed 10 years ago by guillaume.debure@…

Guys, are you able to use wget instead of curl ? wget seems to work fine, and I can't reproduce the curl issue. Or, to be more accurate, I have a different issue: curl returns the source HTML of http://skrooge.org. I can't figure out why, at the moment.

If wget is an option, it might just work.

comment:34 Changed 10 years ago by mkae (Marko Käning)

No, we can't use wget as curl is used by MacPorts to download distfiles.

Sorry.

comment:35 Changed 10 years ago by guillaume.debure@…

Cc: guillaume.debure@… added

Cc Me!

comment:36 in reply to:  34 Changed 10 years ago by guillaume.debure@…

Replying to mk@…:

No, we can't use wget as curl is used by MacPorts to download distfiles.

Sorry.

OK, back to trying to fix the curl issue then :p

comment:37 Changed 10 years ago by stephane@…

Hi,

Curl issue is now corrected

Could you update the portfile to download the following file ? http://skrooge.org/files/skrooge-0.8.0.4.tar.bz2

Thank you.

comment:38 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane,

in r75528 I eventually introduced - the initially wished for - port named skrooge, thanks to the efforts you put into the curl issue.

So, what do we do with skrooge-devel now. It could be we should make it obsolete, because I think skrooge is easier to maintain. As soon as you upload a new distribution (like 0.8.0.5) a call of "port livecheck" on my end would spot this and inform me about your progress. I'd more or less immediately update the port file and everyone would be happy. No need for a ticket with the svn revision number to update to and so on and so forth.

What do you think, Stephane? How to proceed with this?? Abandon skrooge-devel or not to abandon, that is the question!

The only advantage I can see here is that you could keep an unstable version for testing in skrooge-devel and a stable version in skrooge.

It's up to you to decide how to handle this.

Let me know and I'll do what I can to keep skrooge's users happy on MacPorts.

Best regards, Marko

comment:39 Changed 10 years ago by stephane@…

Hi mk,

Thank you for your job.

I don't know what to do because Skrooge does not work correctly on MacOS. We still have a bug: all menu items of plugins are not available in global menu. I tried to find a solution but this is very difficult because I am not a MacOS developer. I tried to find help but without success.

Did you already meet this kind of error on an other kde application ? Do you know somebody able to help me ?

Thank you in advance for your help and advices.

comment:40 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane,

I am not a MacOS developer either. I am just a decade-long Linux guy who happened to get an iMac as a birthday present. When I found MacPorts I was very happy that it offers most of the open source stuff known from Linux world, which is why this is my main playground. I try to keep KMyMoney-related ports afloat for Mac users (in case of the KDE4 version with great trouble) and by doing so want to give back some to the community, since KMyMoney once helped me a great deal.

Concerning your problem I'd suggest you contact the KMyMoney developers, since I know that they also use plugins which also integrate menu entries into the global menu. If that doesn't help, you can try to contact people like snc, sharky, or michaelld on MacPorts itself for advice, since they are the experts for QT and KDE on MacPorts.

Greets, Marko

P.S.: Well, and I'd suggest to keep the devel port and use the skrooge port only for stable versions, once you got your current problems solved.

comment:41 Changed 10 years ago by mkae (Marko Käning)

Hi Stephane,

it looks like something happened to the file skrooge-0.8.0.4.tar.bz2 since I created the port skrooge. Today I wanted to install it here on my end and got a checksum error. Did you change the files content for some reason after January 28th? I have no other explanation otherwise why the checksum check fails.

Greets, Marko

comment:42 Changed 10 years ago by mkae (Marko Käning)

My goodness, what's going on, now that I installed the devel version I notice that skrooge does not start up anymore, as it did before the upgrade to KDE 4.6...

comment:43 in reply to:  42 Changed 10 years ago by guillaume.debure@…

Replying to mk@…: Is there any error message ? maybe if you try to start skrooge from a command line ?

comment:44 Changed 10 years ago by mkae (Marko Käning)

I usually start it from the command line... And there was no output. I guess I'll have to use dtrace to figure out where it gets stuck.

comment:45 Changed 10 years ago by mkae (Marko Käning)

After having started KMyMoney4 (a KDE4 app) before retrying skrooge it is suddenly possible to run skrooge again. It looks as if KMyMoney4 somehow fixed something for skrooge...

When skrooge starts up the first line visible at the command line output is this one:

unnamed app(14067) mac_set_dbus_address: set session bus address to "unix:path=/tmp/launch-tUwGaN/unix_domain_listener"

Don't know whether this means something... (Well, KMyMoney4 doesn't show this!)

comment:46 in reply to:  41 Changed 10 years ago by stephane@…

Replying to mk@…:

Hi Stephane,

it looks like something happened to the file skrooge-0.8.0.4.tar.bz2 since I created the port skrooge. Today I wanted to install it here on my end and got a checksum error. Did you change the files content for some reason after January 28th? I have no other explanation otherwise why the checksum check fails.

Greets, Marko

It should be ok now (2 files were present in the directory skrooge-0.8.0.4.tar.bz2 and skrooge-0.8.0.4.tar.gz)

comment:47 Changed 10 years ago by mkae (Marko Käning)

FIxed in r75764. (But MacPorts was accessing the bz2 file anyways.)

comment:48 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: reopenedclosed

This a a submission ticket, and as the port is now in the repo, I'm closing it. Open new tickets for bugs.

Note: See TracTickets for help on using tickets.