Opened 10 years ago

Closed 10 years ago

#27869 closed defect (duplicate)

db46 requires java headers

Reported by: nagatomo@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: blair (Blair Zajac), ryandesign (Ryan Schmidt)
Port: db46

Description (last modified by ryandesign (Ryan Schmidt))

bash-3.2$ sudo port install wxmaxima
--->  Computing dependencies for wxMaxima
--->  Dependencies to be installed: libsdl xorg-libXext xorg-libX11
xorg-libxcb python27 db46 gdbm gettext expat ncur
esw openssl readline sqlite3 xorg-libpthread-stubs xorg-xcb-proto libxml2
xorg-util-macros xorg-xcmiscproto xorg-xext
g-xf86bigfontproto xorg-xtrans xorg-libXrandr xorg-randrproto xrender
xorg-renderproto maxima gnuplot gd2 xpm xorg-li
libsm xorg-libice pdflib recode sbcl tk Xft2 tcl xorg-libXScrnSaver
xorg-scrnsaverproto wxWidgets jpeg libpng libsdl_
c libogg libvorbis smpeg libtool tiff
--->  Fetching db46
--->  Verifying checksum(s) for db46
--->  Extracting db46
--->  Applying patches to db46
--->  Configuring db46
Error: db46 requires the Java for Mac OS X development headers.
Error: Download the Java Developer Package from:
<https://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/getS
undleID=20719>
Error: Target org.macports.configure returned: missing Java headers
Error: Failed to install db46
Log for db46 is at:
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_dat
46/main.log
Error: The following dependencies were not installed: libsdl xorg-libXext
xorg-libX11 xorg-libxcb python27 db46 gdbm
xpat ncurses ncursesw openssl readline sqlite3 xorg-libpthread-stubs
xorg-xcb-proto libxml2 xorg-util-macros xorg-xcm
xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXrandr
xorg-randrproto xrender xorg-renderproto maxima gnupl
m xorg-libXt xorg-libsm xorg-libice pdflib recode sbcl tk Xft2 tcl
xorg-libXScrnSaver xorg-scrnsaverproto wxWidgets j
g libsdl_mixer flac libogg libvorbis smpeg libtool tiff
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (1)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: blair@… ryandesign@… added
Description: modified (diff)
Port: db46 added
Resolution: duplicate
Status: newclosed
Summary: Failed to Instal wxmaximadb46 requires java headers

Please use WikiFormatting, fill in the Port and Cc fields (for the port that is actually affected), and most importantly, read the error message the port provided to you, which you copied into the ticket above. The error message tells you what to do to fix the problem. (Or, it should: what you've copied into this ticket is truncated; the correct URL to download the required java developer package from is https://connect.apple.com/cgi-bin/WebObjects/MemberSite.woa/wa/getSoftware?bundleID=20719)

This is a duplicate of #27684.

Note: See TracTickets for help on using tickets.