Opened 10 years ago

Closed 10 years ago

#27871 closed defect (fixed)

xplanet +aqua does not build on a case-sensitive filesystem

Reported by: rechner@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: xplanet

Description

I reported this bug about two years ago on the xplanet forum, and the problem is supposedly fixed in xplanet subversion... but since no new release has been made for quite some time it might be worth patching the 1.2.1 release for Macports.

#include <Quicktime/Quicktime.h>

in src/libimage/WriteImageQT.cpp should be changed to

#include <QuickTime/QuickTime.h>

and

AQUA_LIBS="-framework Quicktime"

in configure should be

AQUA_LIBS="-framework QuickTime"

Change History (1)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.