Opened 10 years ago

Closed 10 years ago

#28004 closed defect (worksforme)

ghostscript @9.00 fails to build on Tiger

Reported by: roberto@… Owned by: takanori@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: tiger jpeg6b Cc: ryandesign (Ryan Schmidt)
Port: ghostscript

Description

Please see attached build log. Perhaps ghostscript needs to build depend on a newer gcc?

Attachments (3)

main.log.bz2 (33.9 KB) - added by roberto@… 10 years ago.
main_20110218.log.bz2 (5.3 KB) - added by roberto@… 10 years ago.
config_20110218.log.bz2 (6.4 KB) - added by roberto@… 10 years ago.

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by roberto@…

Attachment: main.log.bz2 added

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Keywords: tiger added
Owner: changed from macports-tickets@… to takanori@…

Please remember to cc the maintainer.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Nothing to do with gcc versions. No idea where it's getting the idea to use jpeg6b though.

comment:3 Changed 10 years ago by roberto@…

I just tried the build again with ghostscript @9.01. This time it failed but didn't get a chance to try and link to jpeg6b. Please see the updated logs I have attached.

Changed 10 years ago by roberto@…

Attachment: main_20110218.log.bz2 added

Changed 10 years ago by roberto@…

Attachment: config_20110218.log.bz2 added

comment:4 Changed 10 years ago by roberto@…

I just attempted the build again, and it now worked:

sudo port -u upgrade ghostscript
--->  Computing dependencies for ghostscript
--->  Configuring ghostscript
--->  Building ghostscript
--->  Staging ghostscript into destroot
--->  Computing dependencies for ghostscript
--->  Installing ghostscript @9.01_0
--->  Deactivating ghostscript @9.00_4
--->  Activating ghostscript @9.01_0
--->  Cleaning ghostscript
--->  Uninstalling ghostscript @9.00_4

Please feel free to close this bug report.

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Keywords: jpeg6b added
Resolution: worksforme
Status: newclosed

I'm guessing the failure was caused by having the jpeg6b port installed, and that by now you have uninstalled it, which allowed the build to succeed.

You also filed #28615 for a subsequent related problem with graphviz.

Note: See TracTickets for help on using tickets.