Opened 10 years ago

Closed 10 years ago

#28014 closed defect (worksforme)

cclive: unknown option substitute

Reported by: bayonne Owned by: nerdling (Jeremy Lavergne)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: cclive

Description (last modified by ryandesign (Ryan Schmidt))

cclive --help returns:

error: unknown option substitute

port version:
cclive @0.7.1_0
boost @1.45.0_2

OS version: 10.6.6

Change History (8)

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: snc@… removed
Description: modified (diff)
Owner: changed from macports-tickets@… to snc@…
Summary: cclivecclive: unknown option substitute

comment:2 Changed 10 years ago by nerdling (Jeremy Lavergne)

--help runs for me, no problem.

Everything else in your MacPorts up-to-date?

comment:3 in reply to:  2 Changed 10 years ago by bayonne

Replying to snc@…:

--help runs for me, no problem.

Everything else in your MacPorts up-to-date?

MP is up-to-date; a few packages are outdated.

comment:4 in reply to:  2 Changed 10 years ago by bayonne

Replying to snc@…:

--help runs for me, no problem.

Everything else in your MacPorts up-to-date?

After

port upgrade --force cclive

the problem is still there. In fact cclive (without options) prints the same message.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

So far I'm unable to reproduce this.

Are any of these packages the outdated ones you mentioned?

  • boost
  • bzip2
  • cmake
  • curl
  • curl-ca-bundle
  • expat
  • gettext
  • gperf
  • icu
  • libiconv
  • libidn
  • lua
  • ncurses
  • ncursesw
  • openssl
  • pcre
  • perl5
  • perl5.8
  • pkgconfig
  • quvi
  • readline
  • zlib

comment:6 in reply to:  5 Changed 10 years ago by bayonne

Replying to snc@…:

So far I'm unable to reproduce this.

Are any of these packages the outdated ones you mentioned?

I don't think so. I think most of the packages you mentioned were reinstalled by upgrade --force cclive, and I have finished upgrading the rest. The problem is still there.

comment:7 in reply to:  2 Changed 10 years ago by bayonne

Replying to snc@…:

--help runs for me, no problem.

Everything else in your MacPorts up-to-date?

Something was wrong in my .ccliverc file. Sorry.

This ticket can be closed.

comment:8 Changed 10 years ago by nerdling (Jeremy Lavergne)

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.