Opened 9 years ago

Closed 9 years ago

Last modified 7 years ago

#28077 closed defect (fixed)

gconf runtime error with multiple apps

Reported by: watsodw Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: dbevans (David B. Evans), drkp (Dan Ports), cooljeanius (Eric Gallager)
Port: gconf

Description (last modified by mf2k (Frank Schima))

Upgrade to the new version of gconf, now gnome-terminal fails to start with following error:

Failed to summon the GConf demon; exiting.  Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See http://projects.gnome.org/gconf/ for information. (Details -  1: Failed to get connection to session: Command line `dbus-launch --autolaunch=537233c7d8732f36e8be01074d373c87 --binary-syntax --close-stderr' exited with non-zero exit status 1: Autolaunch requested, but X11 support not compiled in.\nCannot continue.\n)

Change History (14)

comment:1 Changed 9 years ago by jaguarul@…

I have the exact same problem, while running 'meld'. I think dbus is seriously broken at the moment.

I managed to recompile dbus with X support (by modifying the Portfile) and hit another error:

Failed to get connection to session: Command line `dbus-launch --autolaunch=dcd4a7ddcfeaaf21e1b9c3444d39597f --binary-syntax --close-stderr' exited with non-zero exit status 1: EOF in dbus-launch reading address from bus daemon\n)

comment:2 Changed 9 years ago by jaguarul@…

Cc: jaguarul@… added

Cc Me!

comment:3 Changed 9 years ago by jaguarul@…

Cc: jaguarul@… removed

Cc Me!

comment:4 Changed 9 years ago by mf2k (Frank Schima)

Cc: devans@… removed
Owner: changed from macports-tickets@… to devans@…

comment:5 Changed 9 years ago by mf2k (Frank Schima)

Description: modified (diff)

comment:6 Changed 9 years ago by drowe@…

I think I am getting the same problem, this time trying to run Gnucash - this has just been updated from 2.4.0_1 to 2.4.0_2 - but it no longer starts up properly. Instead, Gnucash displays error dialogues saying: "The configuration data used to specify default values for Gnucash cannot be found in the default system locations . . . "

This problem has occurred several times before when gconf has been unable to contact dbus. I noticed that gconf has just been updated from 2.28.1_0 to 2.32.0_0 (at the same time as the gnucash update, and a lot of other updates). So I tried reverting gconf to 2.28.1_0 and the new gnucash now seems to work OK

comment:7 Changed 9 years ago by jmroot (Joshua Root)

Cc: devans@… added
Owner: changed from devans@… to ryandesign@…
Port: gconf added; gnome-terminal removed
Summary: gnome-terminal and gconf errorgconf runtime error with multiple apps

comment:8 Changed 9 years ago by ryandesign (Ryan Schmidt)

I guess this was assigned to me because I was the one who updated gconf, but I only did so because I noticed the update was available; I don't deliberately use or know anything about gconf. I can revert gconf to the previous version, and/or someone could report this issue to the developers of gconf and see if there is another solution.

comment:9 Changed 9 years ago by info@…

I am seeing the same problem. I've just installed MacPorts for the first time, on a new mac, and Gnucash is giving the same issues as above.

I tried activating an earlier version of gconf (download 2.28.1_0 from svn and install), but the issue seems to remain, even after a reboot. Gnucash still asks me for configuration settings each time - as above.

comment:10 Changed 9 years ago by drkp (Dan Ports)

Cc: dports@… added

Cc Me!

comment:11 Changed 9 years ago by drkp (Dan Ports)

I'm hitting this too, and reverting to gconf 2.28 fixed it.

Unless someone actually knows what's going on, and preferably how to fix it (I certainly don't), I say we back out the upgrade for now.

comment:12 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Reverted in r75352.

comment:13 Changed 7 years ago by dbevans (David B. Evans)

Please see proposed fix for root cause in #39145.

comment:14 Changed 7 years ago by cooljeanius (Eric Gallager)

Cc: egall@… added

Cc Me!

Note: See TracTickets for help on using tickets.