Opened 10 years ago

Closed 10 years ago

#28118 closed defect (fixed)

py26-numpy: Support +universal+atlas

Reported by: richard.e.brown@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: bonoba@…, cubranic@…, jeremyhu (Jeremy Huddleston Sequoia)
Port: py26-numpy

Description (last modified by mf2k (Frank Schima))

Folks,

I have been using macports forever (a couple years). Last night, I tried to upgrade all outdated ports. I got this error message:

--->  Computing dependencies for py26-cairo
Error: Cannot install py26-cairo for the arch(s) 'i386 x86_64' because
Error: its dependency py26-numpy does not build for the required arch(s) by default
Error: and does not have a universal variant.
Error: Unable to upgrade port: architecture mismatch

Attachments (1)

py26numpyerrorlog.rtf (56.0 KB) - added by shane.wilkins@… 10 years ago.
error log

Download all attachments as: .zip

Change History (21)

comment:1 Changed 10 years ago by richard.e.brown@…

Update: I had just upgraded to 10.6.6 hours previously...

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to mcalhoun@…
Port: py26-cairo added

Please remember to fill in the Port field and cc the maintainer.

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Description: modified (diff)

What is the output of the following?

port installed py26-cairo py26-numpy

comment:4 Changed 10 years ago by bonoba@…

Cc: bonoba@… added

Cc Me!

Changed 10 years ago by shane.wilkins@…

Attachment: py26numpyerrorlog.rtf added

error log

comment:5 Changed 10 years ago by shane.wilkins@…

I'm having the same issue. When I do port installed py26-cairo py26-numpy I get:

The following ports are currently installed:
  py26-cairo @1.8.10_0+universal
  py26-cairo @1.8.10_1 (active)
  py26-numpy @1.5.0_1+atlas+gcc44+universal
  py26-numpy @1.5.1_0+atlas+gcc44+universal
  py26-numpy @1.5.1_1+atlas+gcc44 (active)

I've attached the output of {{{port -d upgrade py26-numpy}}

comment:6 in reply to:  5 Changed 10 years ago by mf2k (Frank Schima)

Replying to shane.wilkins@…:

I'm having the same issue. When I do port installed py26-cairo py26-numpy I get:

Your output shows no error. In fact it shows that you were successful in updating to the latest version. the port installed command confirms that.

comment:7 Changed 10 years ago by cubranic@…

Cc: cubranic@… added

Cc Me!

comment:8 Changed 10 years ago by cubranic@…

The problem is that @1.5.1_0 had a universal variant, and @1.5.1_1 does not.

comment:9 in reply to:  8 Changed 10 years ago by cubranic@…

Replying to cubranic@…:

The problem is that @1.5.1_0 had a universal variant, and @1.5.1_1 does not.

py26-numpy, that is.

comment:10 Changed 10 years ago by cubranic@…

I had the same problem, caused by numpy's upgrade to @1.5.1_1 that did not include the universal variant. The variant is available now, so you can upgrade py26-cairo and py26-numpy to use the universal variant. (You may have to use the "--enforce-variants +universal" flag.)

comment:11 in reply to:  10 ; Changed 10 years ago by andre.david@…

I am having the same problem, not because of py26-cairo, but because of py26-matplotlib.

Replying to cubranic@…:

The variant is available now, so you can upgrade py26-cairo and py26-numpy to use the universal variant.

I don't understand your statement. I just synchronized my tree and I still get no universal variant for py26-numpy:

$ port variants py26-numpy
py26-numpy has the variants:
[+]atlas: Use the MacPorts' ATLAS libraries  instead of Apple's Accelerate framework
   gcc43: Use the gcc43 compiler (enables fortran linking)
     * conflicts with gcc44 gcc45
(+)gcc44: Use the gcc44 compiler (enables fortran linking)
     * conflicts with gcc43 gcc45
   gcc45: Use the gcc45 compiler (enables fortran linking)
     * conflicts with gcc43 gcc44

comment:12 in reply to:  11 Changed 10 years ago by cubranic@…

Replying to andre.david@…:

I don't understand your statement. I just synchronized my tree and I still get no universal variant for py26-numpy:

I had the same issue: port variants didn't show "universal", but upgrading found it none the less.

comment:13 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Port: py26-numpy added; py26-cairo removed
Summary: Can't upgrade py26-cairo on MacBook Propy26-numpy: Support +universal+atlas

The problem is with py26-numpy. py26-numpy assumes that it can't have both +universal and +atlas variants. This should not be the case. Atlas builds +universal.

comment:14 Changed 10 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Cc: jeremyhu@… added

Cc Me!

comment:15 in reply to:  description Changed 10 years ago by richard.e.brown@…

Folks,

I have watched the comments over the last couple weeks, but I'm not sure what I need to do to get back on the air. I'm still having the problem below:

Many thanks,

Rich Brown Hanover, NH

% sudo port install rednotebook Password: ---> Computing dependencies for rednotebook Error: Cannot install py26-cairo for the arch(s) 'i386 x86_64' because Error: its dependency py26-numpy does not build for the required arch(s) by default Error: and does not have a universal variant. Error: Unable to execute port: architecture mismatch To report a bug, see <http://guide.macports.org/#project.tickets> %

comment:16 Changed 10 years ago by Veence (Vincent)

This should now be fixed with r76870. Please try again and verify.

comment:17 Changed 10 years ago by richard.e.brown@…

Thanks for the note. I did try "sudo port install py26-cairo", but got the same error message. Sorry to be dim, but what should I be using? Thanks.

comment:18 Changed 10 years ago by Veence (Vincent)

Please verify that you have the r76870 revision of the portfile. It may take a while to propagate.

comment:19 Changed 10 years ago by richard.e.brown@…

YES! That seems to have fixed it. Thanks for diggin' into this.

comment:20 Changed 10 years ago by Veence (Vincent)

Resolution: fixed
Status: newclosed

My pleasure. Have fun.

Note: See TracTickets for help on using tickets.