Opened 10 years ago

Closed 9 years ago

#28195 closed defect (worksforme)

gcc44: build failure, gcj ICE building libjava

Reported by: hsinlun.kuo@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: gcc44

Description (last modified by ryandesign (Ryan Schmidt))

I've been trying to install miriad with macports. But it always stopped at building gcc44. Here is the error message:

Error: Target org.macports.build returned: shell command failed (see log for details)
Log for gcc44 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_gcc44/main.log
Error: Status 1 encountered during processing.

I've tried to clean and install gcc44 separately and no luck there. I'm currently using Snow Leopard (Mac OS X 10.6.6) and Xcode 3.2. I also attach the log file. Could anyone please help me?

Attachments (2)

partial.log (16.1 KB) - added by hsinlun.kuo@… 10 years ago.
last part of the main log for building gcc44
mainlog.tar.gz (301.4 KB) - added by hsinlun.kuo@… 10 years ago.
main log for building gcc44

Download all attachments as: .zip

Change History (8)

Changed 10 years ago by hsinlun.kuo@…

Attachment: partial.log added

last part of the main log for building gcc44

comment:1 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Keywords: gcc44 removed
Owner: changed from macports-tickets@… to mww@…

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

The log says:

Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

So you may want to do that.

Changed 10 years ago by hsinlun.kuo@…

Attachment: mainlog.tar.gz added

main log for building gcc44

comment:3 in reply to:  2 Changed 10 years ago by hsinlun.kuo@…

I have attached the entire log. Please, anybody know how to fix this?

Replying to ryandesign@…:

The log says:

Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.

So you may want to do that.

comment:4 Changed 10 years ago by hsinlun.kuo@…

I moved /opt/local/ to /opt/local.sav and was finally able to build gcc44. Thanks.

comment:5 Changed 10 years ago by mhlambert@…

My problem was that the system libiconv was being used. This patch corrected that issue:

% diff -u Portfile.sav Portfile
--- Portfile.sav	2010-10-05 16:00:56.000000000 -0400
+++ Portfile	2011-02-06 23:28:19.000000000 -0500
@@ -84,6 +84,7 @@
 		--with-gxx-include-dir=${prefix}/include/${name}/c++/ \
 		--with-gmp=${prefix} \
 		--with-mpfr=${prefix} \
+		--with-libiconv-prefix=${prefix} \
 		--enable-stage1-checking \
 		--disable-multilib
 # do NOT use MacPorts binutils -- they do not work

comment:6 Changed 9 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed
Summary: gcc44 failed to buildgcc44: build failure, gcj ICE building libjava

Closing given comment:4 and the fact that I can't reproduce (and the port has been updated to 4.4.6 in the meantime as well).

Note: See TracTickets for help on using tickets.