Opened 11 years ago

Closed 11 years ago

#28200 closed defect (fixed)

inkscape @0.48.0, Revision 2 - inkscape after bad svg not working.

Reported by: a.y.harano@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: inkscape

Description

Not sure if this is the right bug reporting place, but worth a try.

I use Snow Leopard in 64-bit mode (‘arch=x86_64′ boot flag in com.apple.Boot.plist).

I had used the inkscape 0.48.0 from inkscape site and it was working. Then I installed from MacPort and it was working. I had generated a few svg by hand and tried to open using MacPort's. After that time, I got the message "Inkscape encountered an internal error and will close now." each and every time that I open inkscape, forcing to quit just after it starts to run. I had uninstalled both versions (from the website and MacPort's) and tried to reinstall MacPort's several times (cleaing all, uninstalling and installing, rinse and repeat). The error only occoured in MacPort's.

I managed to install as described in section "Compiling Inkscape with native GTK using MacPorts [experimental]" from http://wiki.inkscape.org/wiki/index.php/CompilingMacOsX (it needed a unlisted dep "xorg-libx11"). Even so, it keeps appearing the same error ("Inkscape encountered an internal error and will close now.") and close just after appearing.

The attached file is Snow Leopard's generated log after running using the native GTK (copy-paste).

Is it related to any log or setting file? If so, where do I have to check for them?

Attachments (1)

log_from_snow_leopard.log (38.1 KB) - added by a.y.harano@… 11 years ago.

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by a.y.harano@…

Attachment: log_from_snow_leopard.log added

comment:1 in reply to:  description Changed 11 years ago by a.y.harano@…

Running in a terminal, gives this:

M:bin y$ ./inkscape
Unable to find: FullScreen

** (inkscape:94249): WARNING **: Unknown verb name: FullScreen
Unable to find: FullScreen
**
Gtk:ERROR:gtkrecentmanager.c:1942:get_icon_fallback: assertion failed: (retval != NULL)

Emergency save activated!
Emergency save completed. Inkscape will close now.
If you can reproduce this crash, please file a bug at www.inkscape.org
with a detailed description of the steps leading to the crash, so we can fix it.

Finding out more about the issue related to "get_icon_fallback: assertion failed: (retval != NULL)", I have found out this: https://bugzilla.gnome.org/show_bug.cgi?id=629878#c17

I saw that gtk2 port has no maintainer right now, but probably the GNOME team will patch something related to this.

comment:2 Changed 11 years ago by su-v

See Inkscape bug 651678 “crashes with assertion failure on startup” - fixed in trunk and for upcoming 0.48.1

Known workaround: install and use gnome or tango icon theme

comment:3 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to devans@…

Please remember to cc the maintainer.

comment:4 Changed 11 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

We're at 0.48.1 now so presumably this is fixed.

Note: See TracTickets for help on using tickets.