Opened 6 years ago

Closed 5 years ago

#28272 closed defect (wontfix)

xulrunner@1.9.2.13 fails to build on Darwin 8, ppc

Reported by: p.d.finn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: tiger Cc: jeremyhu (Jeremy Huddleston Sequoia)
Port: xulrunner

Description

I'm building xulrunner for the first time. All the dependencies build without issue. I'm not quite sure what the problem is. Below is the tail of the build log:

...
:info:build _SEC_IntegerTemplate_Util referenced from libxul expected to be defined in /opt/local/lib/xulrunner/libnssutil3.dylib
:info:build _SEC_NullTemplate_Util referenced from libxul expected to be defined in /opt/local/lib/xulrunner/libnssutil3.dylib
:info:build _SECOID_AlgorithmIDTemplate_Util referenced from libxul expected to be defined in /opt/local/lib/xulrunner/libnssutil3.dylib
:info:build /usr/libexec/gcc/powerpc-apple-darwin8/4.0.1/libtool: internal link edit command failed
:info:build make[3]: *** [libxpcom.dylib] Error 1
:info:build make[2]: *** [libs_tier_toolkit] Error 2
:info:build make[1]: *** [tier_toolkit] Error 2
:info:build make: *** [all] Error 2
:info:build shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_xulrunner/work/mozilla-1.9.2" && /usr/bin/make all includedir="/opt/local/include/xulrunner" idldir="/opt/local/share/idl/xulrunner" installdir="/opt/local/lib/xulrunner" sdkdir="/opt/local/lib/xulrunner" " returned error 2
:error:build Target org.macports.build returned: shell command failed (see log for details)
:debug:build Backtrace: shell command failed (see log for details)
    while executing
"command_exec build"
    (procedure "portbuild::build_main" line 8)
    invoked from within
"$procedure $targetname"
:info:build Warning: the following items did not execute (for xulrunner): org.macports.activate org.macports.build org.macports.destroot org.macports.install
:notice:build Log for xulrunner is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_xulrunner/main.log

Attachments (1)

main.log.gz (294.4 KB) - added by p.d.finn@… 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by jmroot (Joshua Root)

  • Keywords tiger added

Not enough build log, attach the whole thing. Also, Tiger is unsupported.

Changed 6 years ago by p.d.finn@…

comment:2 Changed 6 years ago by p.d.finn@…

I am running tiger, it is true; sorry to bother you with this, but there was nothing in the notes about it not being supported. Unfortunately, upgrading is not an option on my platform. For what its worth, I've attached the log. Which is the last version known to work with Tiger?

comment:3 Changed 6 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Try deactivating the installed xulrunner while building the new one.

comment:4 Changed 5 years ago by jmroot (Joshua Root)

  • Resolution set to wontfix
  • Status changed from new to closed

No response regarding the suggested workaround, so closing due to unsupported platform.

Note: See TracTickets for help on using tickets.