Opened 10 years ago

Closed 9 years ago

#28357 closed defect (fixed)

py26-pyglet does not work with 64-bit python

Reported by: kurt@… Owned by: stromnov (Andrew Stromnov)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ktymacports@…
Port: py26-pyglet

Description

Because python on Snow Leopard is 64-bit, but pyglet on Mac uses Carbon, which is 32-bit only, py26-pyglet currently can not work on Snow Leopard. The port should either be marked as non-working/withdrawn on Snow Leopard (because it is misleading for it to be presented as a working port), or the python26 port should receive a new 32bit variant that is compatible with py26-pyglet.

Attachments (1)

crash_report.txt (33.1 KB) - added by ktymacports@… 10 years ago.
Snow Leopard crash report

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to stromnov@…
Port: py26-pyglet added
Summary: py26-pyglet does not work on snow leopardpy26-pyglet does not work with 64-bit python

Please remember to fill in the Port field and cc the maintainer.

Changed 10 years ago by ktymacports@…

Attachment: crash_report.txt added

Snow Leopard crash report

comment:2 Changed 10 years ago by ktymacports@…

FWIW, another data point:

As an attempted workaround, I converted my entire macports tree to i386, which *should* fix the 32-bit incompatibility (right?) However, my pyglet application crashed. The Mac OS crash reporter output is attached, in case it is helpful.

comment:3 Changed 10 years ago by ktymacports@…

Cc: ktymacports@… added

Cc Me!

comment:4 Changed 9 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: newclosed

Worked around about as much as we can in r89399.

Note: See TracTickets for help on using tickets.