Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#28384 closed defect (duplicate)

dbus fails to install as non root

Reported by: www.macports.org@… Owned by: MarcusCalhoun-Lopez (Marcus Calhoun-Lopez)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: dbus

Description

On a fully updated/upgraded MacPort, while installing ftgl, dbus fails to install, apparently because it can't manage to properly install as a non root user (my MacPort installation is entirely non root).

The installer tries to copy "/Users/laurent/unix/macports/var/macports/software/dbus/1.2.24_1/Library/LaunchAgents/org.freedesktop.dbus-session.plist" to "/Library/LaunchAgents/org.freedesktop.dbus-session.plist" which it obviously fails to do since it's running as a non root user. I guess that it should instead try to copy that file to /Users/laurent/Library/....

--->  Fetching dbus
--->  Attempting to fetch dbus-1.2.24.tar.gz from http://ykf.ca.distfiles.macports.org/MacPorts/mpdistfiles/dbus
--->  Verifying checksum(s) for dbus
--->  Extracting dbus
--->  Applying patches to dbus
--->  Configuring dbus
--->  Building dbus
--->  Staging dbus into destroot
--->  Installing dbus @1.2.24_1
Warning: addgroup only works when running as root.
Warning: The requested group 'messagebus' was not created.
Warning: adduser only works when running as root.
Warning: The requested user 'messagebus' was not created.
--->  Activating dbus @1.2.24_1
Error: Target org.macports.activate returned: error copying "/Users/laurent/unix/macports/var/macports/software/dbus/1.2.24_1/Library/LaunchAgents/org.freedesktop.dbus-session.plist" to "/Library/LaunchAgents/org.freedesktop.dbus-session.plist": permission denied
Error: Failed to install dbus
Log for dbus is at: /Users/laurent/unix/macports/var/macports/logs/_Users_laurent_unix_macports_var_macports_sources_rsync.macports.org_release_ports_devel_dbus/main.log
Error: The following dependencies were not installed: doxygen graphviz pango glib2 dbus urw-fonts xorg-libXaw groff xorg-libXmu gsed
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>

Change History (4)

comment:1 Changed 10 years ago by su-v

Cc: suv-sf@… added

Cc Me!

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to mcalhoun@…
Port: dbus added

Please remember to fill in the Port field and cc the maintainer.

I assume this is what the no_root variant is for?

comment:3 Changed 10 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #26742; please search before filing new tickets.

comment:4 Changed 10 years ago by su-v

Cc: suv-sf@… removed

Cc Me!

Note: See TracTickets for help on using tickets.