Opened 10 years ago

Closed 9 years ago

#28565 closed defect (fixed)

gnome-doc-utils tries to use bad perl path

Reported by: joshmoz@… Owned by: dbevans (David B. Evans)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: haspatch Cc: larryv (Lawrence Velázquez), scanny@…, ryandesign (Ryan Schmidt)
Port: gnome-doc-utils perl5

Description (last modified by jmroot (Joshua Root))

I tried to upgrade gnome-doc-utils today but it failed. Looking in the log I found:

==================================

:info:configure checking for intltool >= 0.35.0... ./configure: /opt/local/bin/intltool-update: /opt/local/bin/perl: bad interpreter: No such file or directory
:info:configure  found
:info:configure configure: error: Your intltool is too old.  You need intltool 0.35.0 or later.
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-doc-utils/work/gnome-doc-utils-0.20.4" && ./configure --prefix=/opt/local --disable-scrollkeeper am_cv_python_pythondir=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/ " returned error 1
:error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
:debug:configure Backtrace: configure failure: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for gnome-doc-utils): org.macports.destroot org.macports.configure org.macports.build
:notice:configure Log for gnome-doc-utils is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gnome_gnome-doc-utils/main.log

==================================

So the problem is that there is nothing at "/opt/local/bin/perl". I've only ever done normal installs and upgrades of perl via macports as a dependency for other things. Never messed with my perl intstall manually. "gnome-doc-utils" shouldn't be trying to configure itself with a perl path that doesn't exist in a normal macports install.

I created a symlink from "/opt/local/bin/perl" to "/opt/local/bin/perl5.12" and that failed because "perl5.12" didn't have the proper perl module dependencies installed. Switching the symlink to "perl5.8" worked because that is what had the proper dep modules installed.

Change History (7)

comment:1 Changed 10 years ago by joshmoz@…

I think this got hosed when MacPorts installed perl5.12 during a routing upgrade. As I mentioned above, even if you create the link to "/opt/local/bin/perl" and point it at 5.12 then you'll get a lot of failures because the new perl doesn't have modules required by other packages.

comment:2 Changed 10 years ago by jmroot (Joshua Root)

Cc: devans@… added
Description: modified (diff)
Port: gnome-doc-utils perl5 added

This is unfortunately just how perl module ports work at the moment. If you install them against perl5.8 and then switch to perl5.12, you have to reinstall them. The ${prefix}/bin/perl link should be provided by perl5 though.

comment:3 in reply to:  2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Replying to jmr@…:

The ${prefix}/bin/perl link should be provided by perl5 though.

He needs to activate the perl5 port, and first deactivate the perl5.8 port.

comment:4 Changed 10 years ago by vulcan_@…

Ah Ha! now i see what i need to do.

i just added a note about apache2 failing to install due to needed a forced activation of the perl5 port .. i thought that was suspicious so i flagged the issue in ticket #28564 and .. #?? .. ummm <another ticket> that ryandesign updated just hours ago.

i see this ..

maky:~ jeffhayes$ port list installed | grep perl
mod_perl2                      @2.0.4          www/mod_perl2
...
p5-yaml                        @0.68           perl/p5-yaml
perl5                          @5.12.3         lang/perl5
perl5.12                       @5.12.3         lang/perl5.12
perl5.8                        @5.8.9          lang/perl5.8

and this

maky:~ jeffhayes$ port info perl5
perl5 @5.12.3 (lang)
Variants:             perl5_10, [+]perl5_12, perl5_8

Description:          Wrapper port for perl 5.x
Homepage:             http://www.perl.org/

Library Dependencies: perl5.12
Platforms:            darwin, freebsd, linux
License:              unknown
Maintainers:          ricci@macports.org, mcalhoun@macports.org

showing me that perl5.12 is the active port .. i will deactivate it and then activate perl5

comment:5 Changed 9 years ago by larryv (Lawrence Velázquez)

Cc: larry.velazquez@… added

Cc Me!

comment:6 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: scanny@… added; devans@… removed
Keywords: haspatch added
Owner: changed from macports-tickets@… to devans@…

Has duplicates #31337 and #32423, the latter of which has a simple patch.

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.