Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

#28572 closed defect (fixed)

valgrind @3.6.1 Segfaults when built with Xcode 4.0

Reported by: geoff@… Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: nerdling (Jeremy Lavergne), m@…
Port: valgrind

Description

Installed smoothly but any attempt to run valgrind Segfaults e.g.

$ valgrind -h
Segmentation fault

MacOS 10.6.6, Xcode 4.0 Build 4A278b

Suspect this may be related to using Xcode 4 compilers? Given that is now v. close to full release I guess needs to be fixed though.

Change History (16)

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to raimue@…

Please remember to cc the maintainer.

comment:2 Changed 10 years ago by raimue (Rainer Müller)

I don't have access to Xcode 4 and cannot test or verify this. Please take this issue upstream and file a bug report there.

comment:3 Changed 10 years ago by nerdling (Jeremy Lavergne)

Cc: snc@… added

Cc Me!

comment:4 Changed 10 years ago by nerdling (Jeremy Lavergne)

I was able to get around this by setting build_arch to i386. Valgrind appears to crash doing 64-bit but not 32-bit.

comment:5 Changed 10 years ago by nerdling (Jeremy Lavergne)

According to raim: 64-bit version runs fine on 32-bit.

Apparently the issue is only when building 64-bit on a 64-bits.

comment:6 Changed 10 years ago by geoff@…

I can confirm I see the same - works if I force a 32bit build on my (I think?) 64bit macbook.

Now running 10.6.7 and w/ the final release Xcode 4 btw.

comment:7 Changed 10 years ago by raimue (Rainer Müller)

comment:8 in reply to:  description Changed 10 years ago by Panajev@…

Building the latest SVN version of valgrind from source works.

$ valgrind --version valgrind-3.7.0.SVN

svn co svn://svn.valgrind.org/valgrind/trunk valgrind cd valgrind/ ./autogen.sh ./configure --prefix=<preferred location> make make instal

The valgrind-devel version refers to an older SVN version which does not have the necessary fix.

"------- Comment #2 From Goffredo Marocchi 2011-04-20 10:58:17 (-) [reply] -------

As I was saying, this happens with 3.7.0-r11524_0, is this such an outdated version?


Yes. The fix is in r11686."

Replying to geoff@…:

Installed smoothly but any attempt to run valgrind Segfaults e.g.

$ valgrind -h
Segmentation fault

MacOS 10.6.6, Xcode 4.0 Build 4A278b

Suspect this may be related to using Xcode 4 compilers? Given that is now v. close to full release I guess needs to be fixed though.

comment:9 Changed 10 years ago by jmroot (Joshua Root)

Summary: valgrind @3.6.1 Segfaultsvalgrind @3.6.1 Segfaults when built with Xcode 4.0

comment:10 Changed 10 years ago by dargo@…

So if the solution was found, can somebody please push out an updated Portfile. Thanks

comment:11 Changed 10 years ago by raimue (Rainer Müller)

I updated valgrind-devel to version 3.7.0-r11863 in r80362. Please try this version with Xcode 4 to which I don't have access to.

comment:12 Changed 10 years ago by geoff@…

I have built valgrind-devel on the same macbook (now running 10.6.8 and Xcode 4.0.1) without any special args and it doesn't segfault so looking good.

comment:13 Changed 10 years ago by m@…

Confirming that valgrind-devel works on my i5 64bit macbook pro, whereas valgrind segfaults. Xcode version 4.0.2.

comment:14 Changed 10 years ago by m@…

Cc: m@… added

Cc Me!

comment:15 Changed 9 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Hopefully fixed with r81375.

comment:16 Changed 9 years ago by raimue (Rainer Müller)

The patch was faulty, updated in r81469.

Note: See TracTickets for help on using tickets.