Opened 10 years ago

Closed 10 years ago

#28574 closed defect (fixed)

mldonkey port build failure after libpng14 update

Reported by: jacf01@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: libpng libpng12 libpng14 Cc: ryandesign (Ryan Schmidt), olaf@…, meckie@…
Port: mldonkey

Description

The mldonkey port is currently broken. The resulting linker options end up specifying both libpng12 (perhaps from the default MacOS libpng-config, which is still at 12) and libpng14 (MacPorts).

Attachments (2)

main.log (436.7 KB) - added by jacf01@… 10 years ago.
main.2.log (117.8 KB) - added by meckie@… 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 10 years ago by jacf01@…

Attachment: main.log added

comment:1 Changed 10 years ago by jacf01@…

Cc: jacf01@… added

Cc Me!

comment:2 Changed 10 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added; jacf01@… removed

Unable to reproduce; builds fine for me. Meanwhile, I updated mldonkey to 3.0.7. Do you still see the problem with that version? If so, perhaps one of its dependencies needs a rebuild. (If you can find out which one it is, let us know.)

comment:3 Changed 10 years ago by olaf@…

Cc: olaf@… added

Cc Me!

comment:4 Changed 10 years ago by meckie@…

same issue, attached main.log

Changed 10 years ago by meckie@…

Attachment: main.2.log added

comment:5 Changed 10 years ago by meckie@…

Cc: meckie@… added

Cc Me!

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: mldonkey removed

Have you already made sure your port definitions are up to date and that there are no outdated ports?

sudo port selfupdate
port outdated
sudo port clean mldonkey outdated
sudo port upgrade outdated

If that doesn't fix it, then please attempt to discover what installed port still wants to use libpng12. Try a brute-force search for "png12", such as:

sudo grep png12 -r /opt/local/{bin,include,lib,sbin} 2>/dev/null

For each identified file, use "port provides" to see what port it came from. That port probably needs to be rebuilt. You can rebuild a port using "sudo port -n upgrade --force" but please also let us know what ports were identified, so we can see if we need to increase their revision.

comment:7 Changed 10 years ago by meckie@…

Issue solved. I had to search for the old dependency and rebuild the lablgtk2.

Thank you very much!

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Thanks, fixed in r78208 by increasing lablgtk2's revision.

Note: See TracTickets for help on using tickets.