Opened 8 years ago

Closed 8 years ago

#28651 closed defect (fixed)

p5-php-serialization @0.34_1 has unnecessary depends_lib, needs license info

Reported by: l2g@… Owned by: hagedorn@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: haspatch Cc:
Port: p5-php-serialization

Description

It looks like the declared dependence on p5-extutils-makemaker is unnecessary because ExtUtils::MakeMaker is already available by default. Also, using "depends_lib" (instead of "depends_lib-append") overwrites any defaults set by the perl5 PortGroup; this may cause things to break in the future if the PortGroup is changed.

Attachments (1)

p5-php-serialization.patch (893 bytes) - added by l2g@… 8 years ago.

Download all attachments as: .zip

Change History (2)

Changed 8 years ago by l2g@…

Attachment: p5-php-serialization.patch added

comment:1 Changed 8 years ago by l2g@…

Resolution: fixed
Status: newclosed

Committed in r76701 with Thomas Hagedorn's blessing.

Note: See TracTickets for help on using tickets.