Opened 16 years ago

Closed 15 years ago

Last modified 5 years ago

#2874 closed defect (invalid)

BUG: emacs +carbon fails during applying patches

Reported by: Martin.Buchmann@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: danchr@…
Port: emacs

Description (last modified by ryandesign (Ryan Schmidt))

I tried to install CarbonEmacs using release1 which i checked out as described on http://darwinports.opendarwin.org/. I removed everything i had installed from the Emacs port before with 'sudo port clean --all emacs' and tried to reinstall the latest CVS built with 'sudo port install emacs +carbon'. The installation procedure is aborted with this message:

--->  Fetching emacs
--->  Verifying checksum(s) for emacs
--->  Extracting emacs
--->  Applying patches to emacs
Error: Target com.apple.patch returned: shell command "cd
"/Users/Martin/darwinports/dports/editors/emacs/work/emacs" && patch -p1 <
"/Users/Martin/darwinports/dports/editors/emacs/files/patch-unexec"" returned
error 1
Command output: can't find file to patch at input line 9
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: emacs/src/unexdyld.c
|===================================================================
|RCS file: /cvs/root/emacs/emacs/src/unexdyld.c,v
|retrieving revision 1.6
|retrieving revision 1.7
|diff -b -u -u -r1.6 -r1.7
|--- unexdyld.c 2002/03/01 02:47:00     1.6
|+++ unexdyld.c 2005/02/17 04:31:30     1.7
--------------------------
File to patch: 
Skip this patch? [y] 
Skipping patch.
2 out of 2 hunks ignored

I checked the other bugs archived for the emacs port but couldn't find anything suitable.

Attachments (1)

debug-output.txt (2.4 KB) - added by Martin.Buchmann@… 16 years ago.
The complete output achieved with option -d

Download all attachments as: .zip

Change History (7)

Changed 16 years ago by Martin.Buchmann@…

Attachment: debug-output.txt added

The complete output achieved with option -d

comment:1 Changed 16 years ago by snu@…

Owner: changed from darwinports-bugs@… to jkh@…
Summary: Installing CarbonEmacs fails during applying patchesBUG: emacs +carbon fails during applying patches

Please assign to maintainer and use summary prefix.

comment:2 Changed 16 years ago by danchr@…

Cc: danchr@… added

I think we should move to using snapshots of CVS until 22.1 is released. It would fix issues like this, and the CVS version of Emacs really is quite stable and usable.

comment:3 Changed 16 years ago by lambda@…

I'm getting this same problem, DarwinPorts 1.001, Mac OS X 10.4 (Tiger). I get the same problem if I do install emacs +carbon, and +gtk. Compiling with +x11 gives me a different problem.

comment:4 Changed 16 years ago by snu@…

Owner: changed from jkh@… to darwinports-bugs@…

Jordan has relinquished maintainership of these ports.

comment:5 Changed 15 years ago by blb@…

Resolution: invalid
Status: newclosed

The emacs port no longer has a carbon variant, as that's now handled by the emacs-devel port (which is also a newer version). If similar issues are present with emacs-devel, please reopen this bug with relevant details.

comment:6 Changed 5 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: emacs added
Note: See TracTickets for help on using tickets.