Opened 10 years ago

Closed 10 years ago

#28970 closed defect (wontfix)

Gwyddion 2.22 unable to save or open more than once

Reported by: geekymcnerd@… Owned by: rowue@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: yeti@…, geekymcnerd@…, peter@…
Port: gwyddion

Description

Gwyddion, once open, will only allow for one attempt to open or save a file. Once the first attempt has been tried (successful or not) the next attempt will result in a blank loading/opening dialog screen. The program does not freeze but it shows no files to open and will not allow for saving. The cursors also becomes an hour glass with in the loading/opening screen. The two images attached show the before and after attempts to open files. There is also an error that occurs in the terminal when attempting to load or save, which is:

(gwyddion:49914): GLib-GObject-CRITICAL : g_object_unref: assertion `G_IS_OBJECT (object)' failed

One last note, before posting this ticket, I tried to downgrade to versions 2.21 and 2.20. Neither of these versions fixed the issue.

I've looked around on google and have not found a fix that has worked as of yet. Any help or guidance would be greatly appreciated.

Attachments (5)

First_Attempt.png (96.0 KB) - added by geekymcnerd@… 10 years ago.
When initially trying to open a file when gwyddion first starts
After_First_Attempt.png (55.3 KB) - added by geekymcnerd@… 10 years ago.
After the first attempt and no files show up to be loaded.
gwyddion_stacktrace.crash (57.1 KB) - added by geekymcnerd@… 10 years ago.
ouput_from_otool_-L (5.1 KB) - added by geekymcnerd@… 10 years ago.
outpot_from_port_ installed (8.7 KB) - added by geekymcnerd@… 10 years ago.

Download all attachments as: .zip

Change History (29)

Changed 10 years ago by geekymcnerd@…

Attachment: First_Attempt.png added

When initially trying to open a file when gwyddion first starts

Changed 10 years ago by geekymcnerd@…

Attachment: After_First_Attempt.png added

After the first attempt and no files show up to be loaded.

comment:1 Changed 10 years ago by jmroot (Joshua Root)

Cc: yeti@… added
Keywords: gwyddion saving opening removed
Owner: changed from macports-tickets@… to rowue@…
Port: gwyddion added

Please remember to fill in the Port field and cc the maintainers.

comment:2 Changed 10 years ago by geekymcnerd@…

Cc: geekymcnerd@… added

Cc Me!

comment:3 Changed 10 years ago by yeti@…

I suspect there is something fishy in your Gtk+ installation/configuration as if this was a Gwyddion-specific problem I would have been reported by others since version 2.20. File loading in Gwyddion has not changed substantially for a long time so all recent versions will probably behave the same.

Could you please try to

export G_DEBUG=fatal-criticals
gwyddion

which will make it abort on the Critical message and once it aborts, get a stack trace?

comment:4 Changed 10 years ago by rowue@…

Status: newassigned

comment:5 Changed 10 years ago by rowue@…

Three short questions:

  • Which version of OS X are you using (10.4, 10.5, 10.6)?
  • Which variant of gwyddion are you using (if any) (no_x11)?
  • Are you using OS Xs native X-Server or the one provided with macports?

Kind regards,

rowue

comment:6 in reply to:  3 ; Changed 10 years ago by geekymcnerd@…

Replying to yeti@…:

I suspect there is something fishy in your Gtk+ installation/configuration as if this was a Gwyddion-specific problem I would have been reported by others since version 2.20. File loading in Gwyddion has not changed substantially for a long time so all recent versions will probably behave the same.

Could you please try to

export G_DEBUG=fatal-criticals
gwyddion

which will make it abort on the Critical message and once it aborts, get a stack trace?

The stack trace is attached to the ticket now.

Changed 10 years ago by geekymcnerd@…

Attachment: gwyddion_stacktrace.crash added

comment:7 in reply to:  5 ; Changed 10 years ago by geekymcnerd@…

Replying to rowue@…:

Three short questions:

  • Which version of OS X are you using (10.4, 10.5, 10.6)?
  • Which variant of gwyddion are you using (if any) (no_x11)?
  • Are you using OS Xs native X-Server or the one provided with macports?

Kind regards,

rowue

I'm running OS X 10.6.7. By variant do you mean version? If so, I'm currently using version 2.22. I believe I'm using the X-server that is native to OS X.

comment:8 in reply to:  7 Changed 10 years ago by rowue@…

Replying to geekymcnerd@…:

Replying to rowue@…:

Three short questions:

[...]

I'm running OS X 10.6.7.

O.K. - let's see how we can help you - I'm running 10.4 and be able to check 10.5 - both 32 bit.

By variant do you mean version? If so, I'm currently using version 2.22.

No, you can select "variants" during configuration and installation. try "port variants gwyddion" and you see the avail variants. If you try to install gwyddion with "no_x11" then you should add this to "INSTALL_PREFIX/etc/macports/variants.conf" where INSTALL_PREFIX means the path to your macports installation (usually "/opt/local/etc").

I believe I'm using the X-server that is native to OS X.

It might be better to change to the "macports" X-Server - do "port search xorg" (and install the packages) - the supplied X-Server is often a little bit out of date (perhaps you will find comments in the faq)

Kind regards,

rowue

comment:9 in reply to:  6 ; Changed 10 years ago by yeti@…

Replying to geekymcnerd@…:

The stack trace is attached to the ticket now.

This is interesting; it crashes directly in Gwyddion code. I cannot find anything suspicious there tough, even using valgrind on Linux so something in the chooser behaves in an unexpected way on OS X.

Rolf, do you know how to get a stack trace with line numbers?

comment:10 in reply to:  9 Changed 10 years ago by rowue@…

Replying to yeti@…:

Replying to geekymcnerd@…:

The stack trace is attached to the ticket now.

This is interesting; it crashes directly in Gwyddion code. I cannot find anything suspicious there tough, even using valgrind on Linux so something in the chooser behaves in an unexpected way on OS X.

Rolf, do you know how to get a stack trace with line numbers?

No, sorry - for OS X > 10.5 there should be a programm named stackshot which might help on this - but for general purpose I've to take a close look (and ask some guys).

Which would be very simple is to add debug-information (flag) to the gcc calls.

It might be interesting that this problem didn't occur under 10.4 (checked 10 Min ago, omicron scala, gwyddion). I can also check 10.5 but I suspect gwyddion is working there too. (Both 32 Bit)

geeky:

Page]?

  • Try xorg-xserver

Yeti: if you look at #28666 they have also some faults with glib2 - maybe we can find some hints there

kr,

Rolf

comment:11 Changed 10 years ago by geekymcnerd@…

When I look at variants for gwyddion I get:

"gwyddion has the variants:

no_x11: Build gwyddion with quartz gl support universal: Build for multiple architectures"

I've installed xorg-server through macports but problem still occurs.

I've also installed Xcode-Tools and it still occurs.

I know that a friend has a MacBook (10.6) that gwyddion does not have this issue with.

Thank you again for the help. Please let me know if there is more that I can try. Thank you!

comment:12 in reply to:  11 Changed 10 years ago by rowue@…

Replying to geekymcnerd@…:

When I look at variants for gwyddion I get:

"gwyddion has the variants:

no_x11: Build gwyddion with quartz gl support universal: Build for multiple architectures"

I've installed xorg-server through macports but problem still occurs.

I've also installed Xcode-Tools and it still occurs.

I know that a friend has a MacBook (10.6) that gwyddion does not have this issue with.

Very interesting ;)

  • Is your friend also running 10.6.7 or another version?
  • Can you (and your friend) do "port installed" and send us the output (library problems)?
  • Might (you both) also send the output of "otool -L /opt/local/bin/gwyddion"?

Thank you again for the help. Please let me know if there is more that I can try. Thank you!

Kind regards,

Rolf

Changed 10 years ago by geekymcnerd@…

Attachment: ouput_from_otool_-L added

Changed 10 years ago by geekymcnerd@…

Attachment: outpot_from_port_ installed added

comment:13 Changed 10 years ago by geekymcnerd@…

I've attached the two outputs from my computer. I'll follow with my friends in a day or so, he is not in town at the moment. If I get into contact with him before he gets back, I'll attach them. I've also remembered there is another shared mac in my office. I will try gwyddion on that one and see if the issue is there as well. If not, I will upload the same outputs from that computer.

Thank you!

comment:14 Changed 10 years ago by yeti@…

Folowing the hypothesis that this is actually a bug in Gwyddion (like asserting something that does not hold on your system but works elsewhere), could you compile it from source code with

export CFLAGS="-O0 -g"

executed before running ./configure to get line numbers in the stack trace?

If you do so run ./configure with --prefix pointing to a scratch directory so that the manually compiled version will not get mixed with anything.

comment:15 in reply to:  14 Changed 10 years ago by rowue@…

Replying to yeti@…:

Folowing the hypothesis that this is actually a bug in Gwyddion (like asserting something that does not hold on your system but works elsewhere), could you compile it from source code with

export CFLAGS="-O0 -g"

executed before running ./configure to get line numbers in the stack trace?

If you do so run ./configure with --prefix pointing to a scratch directory so that the manually compiled version will not get mixed with anything.

I think this can simply be done in the portfile - until I update to 2.23 (2.24) nothing worse should be happen ...

I've also asked a friend who has upgraded to 10.6.7 this evening for help/test - perhaps we will know more on this tomorrow evening.

comment:16 Changed 10 years ago by peter@…

I cannot confirm this.

I freshly installed gwyddion after upgrading to 10.6.7 today and I am able to use the File -> Open dialog more than once successfully. Files are listed, too.

comment:17 Changed 10 years ago by peter@…

Cc: peter@… added

Cc Me!

comment:18 Changed 10 years ago by peter@…

XCode Version 3.2.6

The output from 'port installed' can be found here: http://pastebin.com/E487KPBn

comment:19 Changed 10 years ago by rowue@…

I've updated gwyddion to 2.24 today. I've also added a variant +debug which adds the CFLAGS mentioned by yeti to configure. You should now be able to produce the right output.

comment:20 Changed 10 years ago by geekymcnerd@…

I'm very sorry it's taken me this long to get back to you all.

After finding that gwyddion worked fine on two other computers running 10.6, I decided to see if fully removing MacPorts would correct the issue. Once that was done, I reinstalled gwyddion but the problem continued. After asking a professor here if he had any ideas, he decided to remove the .gwyddion and other folders like it. This managed to correct the problem. It seems that gwyddion was looking for a file in one of these directories and the file was corrupt, causing issues with the program.

Please let me know if I was not clear enough in my explanation.

Thank you all again for the help!

comment:21 Changed 10 years ago by rowue@…

O.K. - Since this seems not be a macports specific issue, I would like to close the ticket. O.K. by you, Yeti and geekymcnerd?

Kind regards,

Rolf

comment:22 Changed 10 years ago by yeti@…

I wonder what was the bad file but that information is probably lost. Also if `other folders like it' included Gtk+ folders it could be anything...

So, OK.

comment:23 Changed 10 years ago by rowue@…

I'll keep the "debug" variant, so we might be able to see more if this happens the next time.

cheers,

Rolf

comment:24 Changed 10 years ago by rowue@…

Resolution: wontfix
Status: assignedclosed
Note: See TracTickets for help on using tickets.