Opened 8 years ago

Closed 8 years ago

#29045 closed defect (fixed)

sshfs-gui fails to install after successful build

Reported by: davidomundo@… Owned by: drkp (Dan Ports)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: kolasin2@…, sean@…, pbagwl@…, f.calboli@…, drkp (Dan Ports)
Port: sshfs-gui

Description

I'm on the latest 2011 Macbook Pro (64-bit kernel).

I'm attaching /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs-gui/main.log

The log says " BUILD SUCCEEDED ", but then fails to copy the files.

Attachments (1)

main.log (106.1 KB) - added by davidomundo@… 8 years ago.
/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs-gui/main.log

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by davidomundo@…

Attachment: main.log added

/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_fuse_sshfs-gui/main.log

comment:1 in reply to:  description ; Changed 8 years ago by ryandesign (Ryan Schmidt)

One problem is that sshfs requires macfuse, and macfuse has been neglected by its developer. In particular, the current stable version of macfuse, the one that's in macports, does not work on the 64-bit kernel.

comment:2 Changed 8 years ago by kolasin2@…

I am having this issue as well. 10.6.7, Mid 2010 13" MBP.

comment:3 Changed 8 years ago by kolasin2@…

Cc: kolasin2@… added

Cc Me!

comment:4 Changed 8 years ago by sean@…

Cc: sean@… added

Cc Me!

comment:5 Changed 8 years ago by pbagwl@…

Cc: pbagwl@… added

Cc Me!

comment:6 in reply to:  1 ; Changed 8 years ago by ryandesign (Ryan Schmidt)

Cc: f.calboli@… added

Has duplicate #30530.

Replying to ryandesign@…:

One problem is that sshfs requires macfuse, and macfuse has been neglected by its developer.

Perhaps this is addressed now by the existence of fuse4x (uninstall macfuse if present, install fuse4x, then clean and install sshfs-gui).

comment:7 Changed 8 years ago by drkp (Dan Ports)

Cc: dports@… added
Owner: changed from macports-tickets@… to dports@…
Status: newassigned

No, this looks like an Xcode 4 problem...

comment:8 Changed 8 years ago by drkp (Dan Ports)

I don't have Xcode 4 handy, but I committed a possible fix in r81573. Does it work now?

comment:9 in reply to:  6 Changed 8 years ago by f.calboli@…

Replying to ryandesign@…:

Has duplicate #30530.

Replying to ryandesign@…:

One problem is that sshfs requires macfuse, and macfuse has been neglected by its developer.

Perhaps this is addressed now by the existence of fuse4x (uninstall macfuse if present, install fuse4x, then clean and install sshfs-gui).

Even if I did that it would not work because macfuse is a dependency of sshfs -- unless I can build sshfs and sshfs-gui with fuse4x there is no way I can do what you suggest

comment:10 Changed 8 years ago by drkp (Dan Ports)

Resolution: fixed
Status: assignedclosed

Confirmed that this is fixed on Lion/Xcode4.

Note: See TracTickets for help on using tickets.