Opened 16 years ago

Closed 16 years ago

Last modified 16 years ago

#2907 closed defect (fixed)

UPDATE: cyrus-sasl2

Reported by: jberry@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: kyle-opendarwinbugzilla@…, pieterb@…
Port:

Description

Adds patch to client.c file to allow building w/gcc 4.0.

Attachments (2)

patch-Portfile (543 bytes) - added by jberry@… 16 years ago.
Patch to Portfile
patch-client.c (295 bytes) - added by jberry@… 16 years ago.
New file patch-client.c

Download all attachments as: .zip

Change History (11)

Changed 16 years ago by jberry@…

Attachment: patch-Portfile added

Patch to Portfile

Changed 16 years ago by jberry@…

Attachment: patch-client.c added

New file patch-client.c

comment:1 Changed 16 years ago by snu@…

Summary: Patch security/cyrus-sasl2UPDATE: cyrus-sasl2

comment:2 Changed 16 years ago by benwill@…

(In reply to comment #2)

Created an attachment (id=1925) [edit] New file patch-client.c

Confirming this fix works.

comment:3 Changed 16 years ago by kyle-opendarwinbugzilla@…

Cc: kyle-opendarwinbugzilla@… added

comment:4 Changed 16 years ago by kyle-opendarwinbugzilla@…

* Bug 3326 has been marked as a duplicate of this bug. *

comment:5 Changed 16 years ago by pieterb@…

This patch has been applied but doesn't solve the issue. I get the same error as listed in Bug 4031 "cyrus-sasl2 doesn't build".

comment:6 Changed 16 years ago by pieterb@…

blocked: 4031

comment:7 Changed 16 years ago by pieterb@…

Cc: pieterb@… added

comment:8 Changed 16 years ago by benwill@…

This patch has been applied but doesn't solve the issue. I get the same error as listed in Bug 4031 "cyrus-sasl2 doesn't build".

This _did_ solve 'the' issue. 4031 is a different problem that only emerged (for me) with zlib 1.2.2 and openssl 0.9.8.

comment:9 Changed 16 years ago by jberry@…

Resolution: fixed
Status: newclosed

This patch has been applied, so I'm closing this bug.

Note: See TracTickets for help on using tickets.