Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#29102 closed defect (duplicate)

automoc: Qt qmake not found!

Reported by: bizzmichael@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt), michaelld (Michael Dickens)
Port: qt4-mac

Description (last modified by ryandesign (Ryan Schmidt))

I decided to do a port upgrade outdated before trying to install kde4. (Trying to install umbrello) I get an error in configuring automoc.

I get this.

Error: Target org.macports.configure returned: configure failure: shell command failed (see log for details)
Log for automoc is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_automoc/main.log
Error: Problem while installing automoc
To report a bug, see <http://guide.macports.org/#project.tickets>

Looking at the log files it says that Qt Make not found. The problem is that when I type qmake it shows that it is installed.

which qmake returns /opt/local/bin/qmake

I have attached the output of the log file.

Attachments (1)

automoc_confige_log.txt (7.1 KB) - added by bizzmichael@… 9 years ago.
automoc configure log file.

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by bizzmichael@…

Attachment: automoc_confige_log.txt added

automoc configure log file.

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: automoc added

comment:2 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Summary: automoc will not configure while trying to port upgrade outdatedautomoc: Qt qmake not found!

Does /opt/local/bin/qmake exist? Is qt4-mac installed and active? This looks like #27085, in which two people reported that this error was fixed by manually activating qt4-mac, since for some reason MacPorts hadn't done so automatically.

comment:3 Changed 9 years ago by bizzmichael@…

"which qmake returns /opt/local/bin/qmake"

comment:4 Changed 9 years ago by bizzmichael@…

Thanks!

ran

"sudo port -f activate qt4-mac @4.7.2_1+quartz"

and then installed automoc and it worked.

comment:5 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: michaelld@… added
Port: qt4-mac added; automoc removed
Resolution: duplicate
Status: newclosed

Weird: qmake (which is provided by the qt4-mac port) existed, but qt4-mac was not active? I'm not sure how that happened, but I'm glad you got it working.

comment:6 Changed 9 years ago by jmroot (Joshua Root)

Maybe it was qmake from qt3?

comment:7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Is that possible? Did you have the qt3 port installed?

comment:8 Changed 9 years ago by bizzmichael@…

That's right. It was qmake from qt3. I say that because I had installed kde3 so that I could install kcachegrind.

After I activated the qt4-mac automoc worked but when I went to install kde4 it said I had a conflict because kd3 was installed. That's when I remembered that I had to install kde3 to install kcachegrind.

Note: See TracTickets for help on using tickets.