Opened 10 years ago

Closed 9 years ago

#29239 closed defect (fixed)

qgis cannot be installed without specifying variants

Reported by: athundt@… Owned by: Veence (Vincent)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc:
Port: qgis

Description (last modified by mf2k (Frank Schima))

qgis fails to install as follows, with python 2.6.1 already installed via macports:

$ sudo port install qgis
--->  Computing dependencies for qgis
--->  Extracting qgis
Error: Qgis requires python.
Error: Target org.macports.extract returned:  Please select a python variant.
Log for qgis is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gis_qgis/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
$python --version
Python 2.6.1

Change History (12)

comment:1 Changed 10 years ago by mf2k (Frank Schima)

Cc: athundt@… removed
Description: modified (diff)
Port: qgis added

comment:2 Changed 10 years ago by mf2k (Frank Schima)

Owner: changed from macports-tickets@… to vince@…

comment:3 Changed 10 years ago by mf2k (Frank Schima)

Macports python26 is at version 2.6.6. You should try running the following:

sudo port install python_select
sudo python_select python26

I cannot reproduce your error. What is in your /opt/local/etc/macports/variants.conf file?

comment:4 Changed 10 years ago by athundt@…

Here is the output of the two items you requested. I apologize for not mentioning that I had already tried python_select. Also, variants.conf appears blank.

~:sudo python_select python26
Selecting version "python26" for python
~:sudo port install qgis
--->  Computing dependencies for qgis
--->  Extracting qgis
Error: Qgis requires python.
Error: Target org.macports.extract returned:  Please select a python variant.
Log for qgis is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_gis_qgis/main.log
Error: Status 1 encountered during processing.
To report a bug, see <http://guide.macports.org/#project.tickets>
~:
~:cat /opt/local/etc/macports/variants.conf
# To specify global variants to use for all port builds,
# customize this file to list variant settings you want.
#
# Any variants specified here that are not supported by
# a port will just be ignored. Multiple variants can be
# specified per line, or one per line is also allowed.
#
# Example:
# +ipv6 +no_x11

comment:5 Changed 10 years ago by jmroot (Joshua Root)

Summary: qgis failing to install due to python related errorqgis cannot be installed without specifying variants

It wants you to specify which version of python to use by selecting one of its variants. See port variants qgis. I guess you want it to choose for you if you don't specify?

comment:6 Changed 10 years ago by jmroot (Joshua Root)

BTW, the python30 variant doesn't work and should be removed.

comment:7 Changed 10 years ago by athundt@…

Yes, i believe qgis should automatically default to the variant using the result of python --version.

comment:8 Changed 10 years ago by Veence (Vincent)

I will try to implement the necessary modifications. I am off for Easter vacations with no Mac at hand, but I'll try to cope nevertheless. I'll keep you posted.

comment:9 Changed 10 years ago by mf2k (Frank Schima)

I see why it worked for me. I have +python26 in my variants.conf file and doing a "port info qgis" shows (+)python26 as a default, but that comes from my variants.conf. I thought it was a default for the port.

comment:10 Changed 10 years ago by Veence (Vincent)

Sorry for being late on this. I have to rebuild quite a lot of dependencies (e.g. Qt4) and it takes quite a lot of time since I don't have a last-generation machine. I'm working on it though.

comment:11 Changed 10 years ago by athundt@…

Don't worry, no need rush for me personally. I've managed to get qgis working by specifying the python version by hand. The automation is just a convenience for both myself and other users. Thanks for the help!

comment:12 in reply to:  7 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Replying to athundt@…:

Yes, i believe qgis should automatically default to the variant using the result of python --version.

No, ports should not do this.

But I agree qgis should have some default version of python. And this was done in r87346.

Note: See TracTickets for help on using tickets.