Opened 9 years ago

Closed 9 years ago

#29260 closed defect (duplicate)

Error: Failed to install db46

Reported by: enomao@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone:
Component: ports Version: 1.9.2
Keywords: Cc: ryandesign (Ryan Schmidt)
Port: db46

Description (last modified by ryandesign (Ryan Schmidt))

Hello,

I am trying to install arb on my macbookpro (2011, 2.2ghz). Upon executing the command to download and install arb and its dependencies, I get the following error:

--->  Building db46
Error: Target org.macports.build returned: shell command failed (see log for details)
Error: Failed to install db46
Log for db46 is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_db46/main.log

I am at loss to try to solve this problem. I have searched many forums, but none seem to provide a solution.

Just so you know, I have installed xcodes from the DVD and then did a system update with apple, then installed macports.

Apologies if this has already been solved, and I just havent' seen it

Thanks,
Enoma

Attachments (1)

main.log (630.0 KB) - added by enomao@… 9 years ago.
db46 install log fine

Download all attachments as: .zip

Change History (4)

comment:1 Changed 9 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Description: modified (diff)
Owner: changed from macports-tickets@… to blair@…
Port: db46 added

We certainly need to see the main.log file to know what went wrong.

Changed 9 years ago by enomao@…

Attachment: main.log added

db46 install log fine

comment:2 Changed 9 years ago by enomao@…

Hello, I have attached the db46 log fine. Thanks for your help with this. Enoma

comment:3 Changed 9 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed
:info:build ../dist/../libdb_java/db_java_wrap.c:123:17: error: jni.h: No such file or directory

Duplicate of #29115.

Note: See TracTickets for help on using tickets.